Correct channel for serial terminal EC25

When using a serial terminal to send AT commands to my EC25-AF, I generally have used channel 2. That is when I was using the modem in QMI mode, (usbnet,0) but now I want to use the modem in ECM mode, and the only channel I can get it to connect on is channel 0 and it doesnt seem to work with any at commands.
How can I open a serial connection with channel 2 in ECM mode?

Thank you!

Hi @LoneRager

I think you should test under linux host, right? If the usb driver is not installed correctly, this will cause the option and network card to be recognized. So could you show the lsusb -t . and which kernel version you are using.
The AT port is usually /dev/ttyUSB2, which is the second ttyUSB port created by the USB serial option
driver, you can also sen AT via modem prot
/dev/ttyUSB0 — DM
/dev/ttyUSB1 — GNSS
/dev/ttyUSB2 — AT
/dev/ttyUSB3 — modem