Connecting BG95-M3 modem to a GSM network

I am using BG95-M3 modem. I am trying to force the modem to connect to a GSM network.
By issuing the sequence of commands below. Does the sequence look correct to connect to a GSM network?
For some reason, the modem fails to register.
AT+QCFG=“iotopmode”, 0

Hi ,
Do you use AT+QCFG=“band” to correctly configure GSMband? Do you check whether the USIM card supports GSM network?

I left the GSM band at a default setting. I believe there is GSM 1800 and 850 in my area. I am using KORE wireless SIM card and it supports a GSM network. I wonder if there is a way to verify if a GSM network is available in my area. Is there a command I could issue to the modem to check for a GSM network?

Thank you

  1. You can query the current network through the following command:


+QNWINFO: < AcT> ,< oper> ,< band> ,< channel>

  1. If you want to try to force your modem to connect to the GSM network, you can run the following command:



To check what network (GSM or LTE) is available in your area:
Read the AT command document for more details.

I sent the following commands to the modem (as you recommended):

And the response is - +QNWINFO: “GSM”,“310260”,“GSM 1800”,584
Does it mean the modem is connected to a GSM network?

You can use AT+CREG? Command to check whether the module has registered with the GSM network.If the return value is 0,1 or 0,5, the module has successfully registered with the network.


+CREG: < n> ,< stat>
< n>Integer type.
0 Disable network registration unsolicited result code
1 Enable network registration unsolicited result code: +CREG:
2 Enable network registration and location information unsolicited result code:
+CREG: < stat> [,[<lac>],[<ci>],[<AcT>]
< stat> Integer type. Circuit mode registration status.
0 Not registered. MT is not currently searching an operator to register to
1 Registered, home network
2 Not registered, but MT is currently trying to attach the network or searching an
operator to register to
3 Registration denied
4 Unknown
5 Registered, roaming

I actually use this command and the modem response is always +CEREG: 0,2 or +CEREG: 0,4 when I force it to connect to the GSM.
When the modem connects to the eMTC network the response is +CEREG: 0,1 and everything works, but not when I am making to connect to the GSM (+CEREG: 0,2 or +CEREG: 0,4)

Check whether the GSM network is registered successfully. Do I need to use AT+CREG? Instead of AT+CEREG? Please use AT+CREG? Command to query information.

Try AT+CGREG? for GPRS/EDGE connection and AT+CEREG? for LTE.