Compiling drivers for linux problem?

I was trying to install the quectel drivers on ubuntu 11.3 but I get a warning that it was built by gcc from 11.2, and then several errors during compile of option.c, init tty_struct from incompatible pointer type…?

Hi friend,

Please show the logs.

It appears to have worked on reboot. Now it says no sim card present. Is there something I need to do to set it up in linux? I tried it in win 10 pro and it gets no signal and wont connect, but the sim card info comes up fine with the phone number and sim card id and imei.

Have you tried some AT command like


If the modem cannot detect the SIM card, mostly it is caused by the hardware issue,

How do I send that command to the modem in win 10 and linux? The sim hardware must be working correctly for the sim info to come up in windows but not in linux. The modem works fine plugging it directly in a separate router running Rooter.

What’s the OS? It’s like Debian or Yocto/OpenWrt?
Normally there would be 3 ttyUSB and one internet interface on the Linux.
It’s better to provide the kernel log.
If the ttyUSB exists, you can send AT through ttyUSB2 like:
busybox microcom /dev/ttyUSB2

ubuntu 11.3

i will have to check out the logs

Can you email me the latest firmware for the RM520NGL and the RM500QGL. Maybe that will get them working.