CME error 611 when trying to upload file from UFS to FTP server


I am trying to upload a file from UFS to a FTP server, using the UC200T.
This was what I did:

  1. Login to FTP server.
  2. Use the AT+QFTPPUT command.

The screenshot below shows the list of files in the UFS:

I tried to use one of the files (test2.txt). The filename was correct, but the error 611 description was “failed to open file”. May I know what was wrong? I was following the example (pg.17-18) of the FTP AT commands manual v1.1 for UC20.

(P/S - The login to the FTP server was already done prior to this screenshot.)

Thank you.

Best regards,

Please change the command to AT+QFTPPUT=“tesst2.text”,“UFS:test2.txt”,0 to have a try. Thanks!

Hi Kyson,

Thanks for the fast response. I have tried your suggestion, but the UC200T returned an error. Please see the screenshot below (the PDP context was activated already, and I already login to the FTP server).


After powering the UC200T down, and powering up again, and doing the steps again, the result was the same.

Also, can I check the following with you:

  1. When I used the reset function (AT+QRST), there was also the same error message. May I know what could be the reason?

  2. Using the AT+QLFS=“UFS” command, I found the size of the UFS storage, which the total size is about 900kbytes. I understand that the size of the flash storage on UC200T is 16MB, so does it mean the UFS is part of the flash storage? And is there any way to make this bigger?

Thank you.

Dear Sir,
If that, you can try to upgrade the module firmware to have a try.
And Please note UC200T cannot support AT+QRST command, if you want to reset module, you can try AT+CFUN=1,1.
The UFS size cannot make bigger except to delete the file existed in UFS. Thanks!

Hi Kyson,

Thanks again for the help. I will give it a try.