Cat-1 based EG915Q-NA module behaviour is unstable

Hi @all,
We recently upgraded to the EG915Q-NA module(CAT1-based) for our project board. The sim we use is from Twilio (Super Sim). I’m in India and I’m observing the following behavior in the module. My case shows same value for all 3 reg commands( cgreg, cereg, creg) identically.(so cereg,creg also has same value on all the places where cgreg is mentioned)

Sometimes(very few times)
1. it can Register to the network(cgreg:0,5)(If I didn’t set any APN) but anyway, the connection is unstable

Most of the times
2. if I set the correct APN from Twilio - It is not getting connected and the registration status goes from CGREG:0,2 to CGREG:0,0 within seconds.
Screenshot from 2024-04-23 19-41-32

  1. If I didn’t set the correct APN - It goes from CGREG:0,2 to CGREG:0,3 within seconds

Somebody, please explain this behavior and also the solution for the same. I can provide more info if you want.


EG915Q is a cat1 module. you should use AT+CEREG? To query network status, AT+CGREG is usually applied to GSM network registration status query

Thanks for the reply.
I’ve got the point that we should use AT+CEREG for cat1.
But yeah that also I did as mentioned above.(My case shows same value for all 3 reg commands( cgreg, cereg, creg) identically.(so cereg,creg also has same value on all the places where cgreg is mentioned))

So CEREG also turns to 0,0 within seconds.

Please execute this command, and do it many times


I’m Getting Error for this AT CMD (+CME ERROR: 4)
Screenshot from 2024-04-24 08-54-56

Seems like the error is due to me directly copy pasting your command and the double quotes encoding is wrong.
So when I manually entered the command it returns response

And I am getting below response (for more than 5 mins and still the same)
Screenshot from 2024-04-24 10-43-03

Is the terminal connected to the antenna? Why is it always searching the radio network?

Yes, the Antenna is intact and it can even connect to the network a few times, you can refer to the recording below for reference. My question is only a few times it connects but most of the time it isn’t.
But the same board, with same module and same supersim type is getting connected in the US everytime within seconds.

According to the analysis of the logs provided by you, the terminal registration network is rejected before APN is configured.After the APN is configured, the network registration is completed.
Therefore, you need to configure the APN immediately after the module is initialized, and then check the registered network status and IP address again

Even if I set the APN at start, it is not connecting most of the times(CEREG Goes from 2 to 0). The connection happens only a few times (in India). Refer the below log
at-log-not-connecting.txt (42.0 KB)

Below is the log of QENG Servingcell and neighbourcell when it is got connected to the network if you need.

pls run
add a AT Command


This is a command for manual operator selection(as JIO) right?
after setting this, the registration status goes to restricted(0,3) state immediately(even with the correct APN)

network scan output(at+cops=?)


I’ve tried a local sim in India(JIO) which is able to connect in EG915Q-NA with the APN

in that sim after the registration is successful(cereg:0,1)
I tried to run the pppd daemon like below
pppd call quectel-pppd &
but I’m getting the error as “Could not determine local IP address”
I’ve attached the full log of pppd cmd
pppd script failure.txt (3.5 KB)

you need run


JIO network maybe only ipv6

+CGPADDR: 1,“”
this is the output

but I need ppp0 interface with the IP to actually use it right?
how to bring it up?

It indicates only ipv6 addresses

I’m getting +QPING: 569 for the above command

even If I try AT+QPING=1,“”
I’m getting same result

I made it work. After adding custom ipv6-up and ipv6-down scripts
ipv6-down.txt (784 Bytes)
ipv6-up.txt (922 Bytes)

So now I can ping google with ppp0 interface

But I tried the same approach with Twilio Supersim(which supports JIO in roaming) which doesn’t even get register most of the times. Any suggestion on that would be appreciable!

JIO only supports IPV6, so your server or accessing server needs to support IPV6, including DNS and the IPV6 domain name of the accessing server