Can't set LC29HAA to a 10 Hz fix rate

Im trying to set 10Hz Fix rate in LC29HAA module. I tried the following commands:

#Configure time rate

#Save parameters

when i reset the module as the protocol spec specifies, i see NMEA messages every 500ms instead of 100ms (10Hz). But even when i send PAIR051 the module answers 100, but the messages are every 500ms.


What could be wrong? the baudrate is set to 115200.

The version of firmware.

Can someone help me please?

Hello @Anibal_Alejandro_Gua ,

Have you read the documentation that came with the drivers?
Have you tried to speak with forum moderators About - Quectel Forums ?
You can always send an email to:, or,
Remembering that the “american way”, super straightforward not work with oriental culture.
That’s mean that you should be quite formal, polite and humble in your requests.
This is a key that open their hearts, and give you a chance to solve your problem faster.

Have a great evening, :slight_smile:

Hi Anibal_alejandro_Gua,

I test on my LC29HAA evaluation board. With the same firmware and same commands, there is no simillar problem when changing fix rate. LC29HAA will change fix rate once you send the command.

Did you test with EVB(evaluation board) or your own design?
If you test with your own design, please check NMEA output from TXD pin.

Changing fix rate to 10Hz should follow the steps below:

  1. $PAIR050,100*22 → Set 10Hz fix rate, and module change to 10Hz immediately
  2. $PAIR382,1*2E → enable system lock
  3. $PAIR003*39 → power off GNSS system
  4. $PAIR513*3D → save parameters. If you send this command without stopping GNSS(when fix rate > 1Hz), it would be failed to save parameter.
  5. $PAIR002*38 → power on GNSS system

By the way, I will send you the latest LC29HAA firmware via message.

Best regards.

1 Like