Can't Detect EC25 Via ADB Command

Hello,

I have an issue to detect the EC25 module on Linux.
The firmware version is EC25EFAR06A03M4G_OCPU_01.001.01.001.zip. I’ve upgraded the FW with this version and seems like the ADB is not working properly.
I’ve tried the command below and the module is not detected.
$ adb devices

I’ve tried on 3 systems, Windows, Linux and Mac OS. ADB works with all my modules and also worked with this one before the firmware upgrade. I even went and debugged it at the USB layer in Linux, the ADB port is there but it is impossible to attach it to any driver.
I get a unknown device error, so I think it is just not enabled somehow in this firmware. Maybe there is some special command which we are missing. Any advice would be appreciated.

Thanks.

Do you see that port available with cat /sys/kernel/debug/usb/devices ?

Yes, I tried it before.
I can see the port but it has no attached driver.

On my Linux machine I had to add the following to /etc/udev/rules.d/51-android.rules :

SUBSYSTEM=="usb",ATTRS{idVendor}=="2c7c",ATTRS{idProduct}=="0125",MODE="0666",GROUP="plugdev"

Then it is working fine?

I have tried it but no luck yet.
Also that command is only for Linux, it is not required in Windows.
So I am trying to do this in Windows… please let me know if you have any suggestions.
Thanks in advance.

Yes, that worked fine.
You need to run sudo udevadm control --reload-rules after changing the file. That is for Linux only, indeed. I had no way to test with adb on Windows.

I think there is something wrong with the firmware. Even in Windows it keeps throwing errors about a microphone device when I plug it in. And it is unstable. Maybe the Microphone / Speaker device errors interrupt ADB somehow. Do you know how to disable the USB microphone / speaker devices?

I’ve flashed the module with another firmware now that I have. Everything is working fine with the other firmware so I know it’s not the module. I think there might be a problem with EC25EFAR06A03M4G_OCPU_01.001.01.001.zip. If you have a Quectel SDK user guide, would you mind sending me the document? Thanks.

I do not have a Quectel SDK user guide, but I have this (I believe that is from the AT-commands guide):
+QCFG: "usbcfg",<vid>,<pid>,<diag>,<nmea>,<at_port>,<modem>,<rmnet>,<adb>,<uac>
My understanding that <uac> corresponds to USB microphone / speaker devices you mentioned.

I think my FW is broken. If you have the EC25 FW, would you mind sharing it with me?
Thanks in advance.

Finally, I’ve figured out the issue.
The firmware is obviously not designed for ADB to work.
There lots of different things, I had to hack the firmware quite a bit.

Hi Paul,

I think EC25 should support ADB function, so you could try command <at+qcfg=“usbcfg”> to check whether the ADB function is enabled or not.

Br,
Zach

Hi Zach,

Thanks for your reply. I have another question.
According to the latest news from Quectel, the EC series is end of life and replaced by the EG series. If it’s true, I think I should use a different module. I’d like to confirm it. Any advice would be appreciated.

Thanks,
Paul.

Hi Paul,

Regarding this EC is end of life issue, I never heard of that. Thus, please contact local sales/FAE to get more precise information.

Br,
Zach

Thanks. Will do that.

Best,
Paul.