BG96 won't register on LTE B1 or B3

Hi all,

I have a BG96 modem, and i’m trying to connect it to either the LTE bands B3 or B1 which are available in my area in Australia, my mobile phone is able to register to a cell tower serving the B3 band on the Telstra network, but my BG96 chip is not finding it.

I have used the following commands to allow B1, B3 on CAT M1 - Telstra Australia.

<--- ATE0
---> ATE0
<--- OK
---> AT+QCFG="band",0000000F,85
<--- OK
---> AT+QCFG="iotopmode",0,1
<--- OK
---> AT+QCFG="nwscanseq",02,1
<--- OK
---> AT+QCFG="nwscanmode",3,1
<--- OK

I have also tried using my spare BG96 modem, with the same result, it will not find any B3 or B1 LTE networks.

Would anyone be able to help me?


1 Like

Telstra’s Cat-M1 is on B28.


How did you get the latest firmware on the BG96 modem. Im trying to download BG96MAR02A08M1G

Have you tried using the “all bands” configuration?
I decided to use it because I was unfamiliar with which operators used which bands.
When I use this, I see Telstra, Optus, and Vodafone.
My 4 parameters are:

+QCFG: "band",<gsmbandval>,<catm1bandval>,<catnb1bandval>,<effect>