BG96 QSSL couldn't to connect to some HOST

Hi. I trying access to https API from BG96/BG77 modules.
Most of the servers can be accessed by using the AT commands shown in the log.
But, couldn’t to connect to some servers.
Can you connect to these host via HTTPS?
Example of a host that cannot connect:

Do you know what’s going wrong?

Logs:

If also set to “AT+QSSLCFG=“ciphersuite”,0,0XFFFF” returns the same result

I also tried it on EC25.
AT+QSSLOPEN=1,0,1,“www.ricoh.com”,443,1
+QSSLOPEN: 1,0
AT+QSSLOPEN=1,0,1,“www.fujitsu.com”,443,1
+QSSLOPEN: 1,550
Oddly enough, also ec25 couldn’t connect to one of the HOST.

On my home EC25,
Both hosts were able to QSSLOPEN by executing the command.
AT+QSSLCFG=“sni”,0,1
I’ll try it with BG77 too in office after the holidays.

A colleague tested and QSSLOPEN was successful on BG77 as well.

Hi

Please try to set this command before create connection: AT+QSSLCFG=“ignorecertchain”,1,1

1 Like

Hi. Thank you for reply.
I’ve never seen that command before.
What effect does that command have?

Wolfssl must import the root certificate for verification, but some SSL server use intermediate certificates, which will cause the certificate verification to fail. For this error, you can use the AT+QSSLCFG=“ignorecertchain” command to configure to ignore the certificate verification.

1 Like

Thank you for teach.
I try it.