BG96: Not getting URC. getting error while setting "urcport"


I couldn’t able to set AT+QURCCFG=“urcport”,“all” on BG96 for (UK) . Getting error. Can anyone help to fix it?


Hi Folks,
Can any one please suggest on this? What would be the possible reasons for Getting “urcport” Error?

Hi Keyur1

I think the AT command you use is wrong that’s why you get the ERROR response.

I just read their document BG96 AT Commands Manual. It says you should only use the "usbat","usbmodem" or "uart1" as a configuration parameter with the AT+QURCCFG="urcport" command.

Here is the Example for you,

Hi Sivasubramanian_R
Thanks for response. Understand we can either select any one of 3 not all Right?


Hi Keyur1

Yes, as far as I know, we can select any one of three.

yes Sivasubramnianion,

as Keyur1 said , we can not set “all” as a parameter in this module