BG96 MQTT issue

I’m engineer in mobility rental service development company.
I bought LM5 ( external LTE module based on BG96 — S.korea. M2MNET ).

I have been using BG96 & AWS IOT CORE.
They are communicating through MQTT with SSL.


  1. I recieve QMTSTAT: 0,1 or QMTSTAT: 0,2 error about 2~3 times per day.
    I’ve already tried solutions on manual ( BG96_MQTT.pdf )
    But none of the solution can’t reconnect to server.
    So I use AT+CFUN=1,1 or HW reset ( pull out power and reconnect )
    Are there any solutions for this?

  2. Why am I recieving QMTSTAT:0,1 or QMTSTAT: 0,2?
    when this error occurs, I checked network status ( AT+QCDS? ) and PDP context ( AT+QIACT? ).
    But result was on normal connection. ( Good network signal , Active PDP context )
    I want to know actual reason with field examples.

  3. Can I make QMTSTAT errors manually?
    I want to test my code with QMTSTAT errors.

Hi Bongbong ,

yes , when you receive QMTSTAT: 0,1 or QMTSTAT: 0,2 , it means mqtt link has been disconnected ,

when you met this issue , you have to reconnect mqtt server again ,

but you donot need to reset hw , you can redo the procedure from AT+QMTOPEN .


Hello BongBong,

Did you ever find a good resolution for this?

I have tried several ways to reset but after I get the QMTSTAT 0,2 I am unable to restart the connection. Like you I have defaulted to just reseting the device and starting over.

Can you show an example or more information on how to reset the device correctly? In app notes I see they do not use QIACT, and I am seeing other ways to activate and deactivate PDP, like using QMTDISC.