BG96 - getting stuck on 2G in United States

We’re seeing BG96 modules, which have default nwscanseq (020301) and nwscanmode (0), sometimes end up on T-Mobile 2G instead of the also available AT&T Cat-M. We are using a SIM that supports both T-Mo and AT&T.

It seems like this network type is cached, because on subsequent power-ups the device preferentially reconnects to 2G even when cat-M is available.

We can force the device to return to Cat-M by altering nwscanmode, and it’ll stay there until the next cat-M network upset, but this is not a very clean option.

Is there a command to cause the device to always scan for Cat-M at power up, so that a device that temporarily finds 2G will automatically switch back to cat-M?

nwscanseq()… reorder and/or remove other

Yeah, that’s not really useful. We have a scan sequence, we’d just like it to start at the top of the sequence vs jumping to 2G if the last connection was 2G.

The only way to get it off 2G is to take 2G out completely. This is not helpful if you are in an area which only has 2G service.

The last network/cell the modem was connected to is preferred by the module. I think there is no way to “delete” it, but maybe you can force the modem to always restart a new scan if you send AT+QCFG=“nwscanseq” again after power on. The drawback is that an automatic scan with all network types enabled can take several minutes (even tens). If you can determine that some networks or bands will never be used, then filter them out, to speed up network search.