BG96 file upload ftps

Hello,

I have a problem opening a file before transferring data to a FileZilla FTP server, My BG96 module returns me after the AT command

AT+QIACT?

OK

AT+QICSGP=1,1,“xxx”,“”,“”,1

OK

AT+QIACT=1

OK

AT+QFTPCFG=“account”,“xx”,“xxx”

OK

AT+QFTPCFG=“contextid”,1

OK

AT+QFTPCFG=“filetype”,1

OK

AT+QFTPCFG=“transmode”,1

OK

AT+QFTPCFG=“rsptimeout”,90

OK

AT+QFTPCFG=“ssltype”,1

OK

AT+QFTPCFG=“sslctxid”,1

OK

AT+QSSLCFG=“ciphersuite”,1, 0xffff

OK

AT+QSSLCFG=“seclevel”,1,1

OK

AT+QSSLCFG=“sslversion”,1,4

OK

AT+QSSLCFG=“cacert”,1,“alticap.crt”

OK

AT+QFTPOPEN=“xxx”,990

OK

+QFTPOPEN: 0,0

AT+QFTPCWD=“/” OK

+QFTPCWD: 0,0

AT+QFTPSTAT OK

+QFTPSTAT: 0,1

AT+QFTPPUT=“test_alti.csv”,“COM:”,0,10,0

+CME ERROR: 609

In BG96, certification files

AT+QFLST=“*”

+QFLST: “alitcapCert.pem”,2004

+QFLST: “alticap.crt”,5298

+QFLST: “alticapKeyPriv.pem”,3292

+QFLST: “security/”,2

OK

alticap,crt

-----BEGIN RSA PRIVATE KEY-----

MIIJ……SRc=

-----END RSA PRIVATE KEY-----

-----BEGIN CERTIFICATE-----

MII….Pg==

-----END CERTIFICATE-----

alticapKeyPriv.pem

-----BEGIN RSA PRIVATE KEY-----

MIIJ……SRc=

-----END RSA PRIVATE KEY-----

alitcapCert.pem

-----BEGIN CERTIFICATE-----

MII….Pg==

-----END CERTIFICATE-----

Please advise the possible cause for BG96 ftps file transfer failure.

Thanks!!

Hi,
Could you tried FTP without SSL? does it works?
from AT logs seems that you didnt configured cert.pem and priv_pem path.

Hello,
We tested on several FTP servers (without SSL) and it works.
With SSL, access is OK (port, username and password). Reading the size of a file is OK. Data GET and PUT functions cause a timeout. So it seems impossible to transfer data. The firmware version is 01.017.01.017 on a BG96MAR02AO7M1G.
Thanks for your help
Cordially
Philip