BG96 - DNS parsing error with MQTT, HTTP, TCP and UDP protocols


When I try to establish a connection between my BG96 and a certain server, I get DNS parsing error messages, which includes HTTP, MQTT, TCP and UDP protocols.

I managed to establish connection and send data once with UDP protocol, but then I used IPv4 address instead of URL. However I could NOT establish a connection with the other protocols (MQTT, HTTP and TCP) using IPv4.

I checked:
The NB-IoT network and SIM, everything seems good.

The domain name of the server is valid.
Protocols configurated with their respective AT commands. (eg. AT+QMTCFG)
PS domain attached and registered.
PDP context is activated.
DNS server is properly set. I even tried to change the default to something, still no luck.

Any idea where might the problem be?

Thank you.

One more thing to add, when I try to open a network for MQTT client with IPv4, at first it successfully connects then disconnents for some reason. Reopening does not work.





Did you find a fix for this? Many thanks!