BG96 and ALDI mobile (Telstra) not registering

Greetings, All. First post. Hope I’m not asking anything with an obvious answer.

Recently bought a LTE IoT 2 Click - MikroElektronika module from an Australian supplier.
Using the main UART interface, I’ve managed to get the GNSS side of the module working to my satisfaction.

Using an ALDI mobile SIM, tested as working in a normal phone, I’ve tried to connect to a local cell.
AT+CREG? only gives 0,0 and AT+CGREG gives 0,4.
This command has been repeated over several minutes, with the same result.
The network status LED on the module indicates I have not registered to a network.
(And the CREG results, above, would seem to back this up.)

I’ve tried two different kinds of LTE antenna in the correct socket!, with no change.
I’ve tried AT&F and AT+CFUN as well as following many other posts across many forums and while they seem to target NB-IoT or CAT-M1 solutions, I still can’t get my module to see the network.

I’ve tried searching for available networks (I have access to all three Australian carriers) yet the only result is a network operated by a railway company.
Being what I assume is a closed network, I could not register with it.

I’ve also tried QNavigator V1.4.
QN, at the end of first initialisation, pops up two windows, one claiming The module model is not matching. Please restart, select correct module and try again!. Then a few seconds later Fail to register to the network!
I could not find a setting to ‘select correct module’, so not sure why that message.

SIM information can be read via AT commands okay.

Have I bought a dud module or is there something I haven’t done?
My intended use for this module is for SMS i/o rather than NB-IoT or CAT-M1.

Module model: BG96MAR02A07M1G

With thanks, in advance.

Hi wofm ,

For BG96 Iot module , it support CATM /NB/GSM network ,

the return value of AT+cgreg? , generally , you need to check SIM card provision ,

BTW , the ‘’AT+cgreg?“” used for check the register status of gsm

if you need to register catm or NB,pls use at+cereg?

for more detail , pls send the following cmd to get more info :



reboot module, then try these command again:







Thanks for the feedback,


at+cgreg… 0,0
at+cereg?.. 0.4
at+cops?.. 0
at+qcsq… 99,99
at+qnwinfo… No Service

This command is not in V2.3 of the AT commands guide. What does it do?

AT+QMBNCFG=“autosel”,0… error

AT+CGDCONT?.. no response
AT+CGCONTRDP… no response
AT+COPS?.. no response
AT+CIMI… no response
AT+QCSQ… no response
AT+QMBNCFG="LIST‘… no response

Did a factory default (AT&F) and repeated above:
AT+CGDCONT?.. “IP”,“”,“”,0,0,0,0 that looks promising
AT+COPS?.. 0
AT+CIMI… received the IMSI for the SIM
+QMBNCFG: “List”,0,0,0,“Att_Non_Volte_Lab”,0x05010310,201712191
+QMBNCFG: “List”,1,0,0,“China_Common”,0x05802800,201806231
+QMBNCFG: “List”,2,0,0,“Telstra-Commercial”,0x05801801,201806301
+QMBNCFG: “List”,3,0,0,“ROW_Commercial”,0x05800801,201806301
+QMBNCFG: “List”,4,0,0,“Verizon_Commercial”,0x05803801,201806301

In bold, above. Telstra resells to ALDImobile, so that’s something.

I’ve just put in a “Boost”-branded SIM (which is a Telstra-owned company).
Summary: getting similar results; can’t register with the LTE network.

What are your thoughts?

Quick addition:

AT&F then AT+CPOL?
+CPOL: 1,2,“50501”,0,0,0,1
+CPOL: 2,2,“50501”,0,0,1,0
This is for the Boost SIM

With the ALDI SIM, it also displayed:
+CPOL: 3,2,“50501”,1,0,0,0

I believe “50501” is Telstra Mobile.

So we’re getting close; it just seems so far away!

In my first post I asked:

“…in QNavigator V1.4., at the end of first initialisation there is a pop-up window claiming The module model is not matching. Please restart, select correct module and try again!…”

Can you advise why this happens, please?

Dear wofm ,

  1. for Qnavigator’s prompt , I think it related with some configuration of navigator , pls ignore this ,

2, Base on the AT return value listed by you , You have not searched the right network ,I highly suspect SIM card is the problem . pls insert this sim card to other Iot module and try , or send email to us for more assistance . we will sent to you log tools for more analysis .

  1. That’s good news. Perhaps the next version of Qnavigator will fix this ‘bug’.

  2. I have tried another brand of SIM in this module, with the same result.
    I think the module may be at fault.
    I have ordered another BG96 product from a different supplier to confirm.
    I’ll provide feedback once it is known.

Thanks for reply.
I’ll email you requesting the log tools.

Hi wofm,

Can I also suggest you try a Telstra branded pre-paid SIM (only cost $2), or even better a post-paid one. I’m not sure if Telstra has restrictions on the wholesale providers from using its IoT network.

Thanks, itesic, for the suggestion.
I’ve already tried a Boost (full Telstra) SIM, with the same results.

Interestingly, I’ve just received a PCIe version of the BG96 and it works fine with the Aldi SIM.
I’m “on the air” within about 15 seconds.
But (!), the PCIe version does not pick up GPS, which the MikroElektronika does.


I’ve also aquired a diagnostic tool from Quectel to assist, however on first glance, it’s not a plug-in and log procedure. Easter weekend job, I feel.

Hey @wofm,

Any luck? Im facing the same issue here in New Zealand :frowning:


Hello, Bash.

In a word, no.
Even a replacement Click from the same Perth-based supplier failed to fully work with QNavigator.

As I mentioned, a BG96 on a PCIe card worked okay.
Don’t know what the issue with the Click is.

I figure I’m just making a ‘beginner’ mistake somewhere (?) and I’m no longer prepared to invest further time trying to get the Click module to work as part of my evaluation of the BG96.


Hi @wofm

I have managed to get it to work. Over the moon is an understatement.

So on the BG96 product page, there seems to be a missing document, the Quectel_BG96_AT_Commands_Manual_V2.3.

There is a very similar one, BG96 QuecCell AT Commands Manual (notice the sneaky “QuecCell”)

I found this document from the hardware notes PDF referenced as document[2], then by searching the title in their entire documents DB.

anyways, here’s the link to the full BG96 AT commands PDF:

make sure you’re logged in to get access.

What I ended up doing is this:

AT&F0 - Set All Current Parameters to Manufacturer Defaults

AT&W0 - Store Current Parameters to User Defined Profile (profile 0)

AT+CFUN=1 - Full functionality (this gave an ERROR for me previously, AT+CFUN? returned a 5 before and I couldn’t change it)

Now you can do whatever the heck you want, including setting the band to B28 and B3, although for me, the NETWORK status LED turned to cell connectivity even without changing the band.

If you need to set the band to AUS/NZ (the cool bands) do:


I hope this helps someone.


Hi Folks,

I am new here and this thread looks similar to my needs. I have a RAK2013 Raspberry Pi Hat that incorporates the BG96. I am Australia and using a Telstra SIM card. I am new to Raspberry Pi so my issue may be more towards the Pi and not the BG96. looking at the above thread I have entered all the AT commands as directed and every looks good to me however I cannot get a cellular connection on my Pi3+. With the USB connected to the Pi and the USB micro connected to the Hat I get the connection notification on my panel with a wwan0 displaying an IP address however there is no internet connection. If I remove the USB cable I get no connection. I want to be able to run this Hat without a cable due to space limitations.

Any suggestions would be most apricated.

+CEREG: 0,1

+CGREG: 0,4

+COPS: 1,0,“Telstra #StaySafe Telstra”,8

+QCSQ: “CAT-M1”,-65,-95,139,-13

+QNWINFO: “CAT-M1”,“50501”,“LTE BAND 28”,9410


pi@raspberrypi:~ $ sudo minicom -D/dev/ttyAMA0 -b 115200

Welcome to minicom 2.7.1

Compiled on Aug 13 2017, 15:25:34.
Port /dev/ttyAMA0, 17:28:31

Press CTRL-A Z for help on special keys

+CGDCONT: 1,“IP”,“Telstra.Internet”,“”,0,0,0,0

+CGCONTRDP: 1,5,Telstra.Internet,,,

+COPS: 1,0,“Telstra #StaySafe Telstra”,8


+QCSQ: “CAT-M1”,-66,-98,138,-13

+QMBNCFG: “List”,0,0,0,“Att_Non_Volte_Lab”,0x05010310,201712191
+QMBNCFG: “List”,1,0,0,“China_Common”,0x05802800,201806231
+QMBNCFG: “List”,2,0,0,“Telstra-Commercial”,0x05801801,201806301
+QMBNCFG: “List”,3,0,0,“ROW_Commercial”,0x05800801,201806301
+QMBNCFG: “List”,4,0,0,“Verizon_Commercial”,0x05803801,201806301

+QCFG: “nwscanmode”,(0,1,3),(0,1)
+QCFG: “nwscanseq”,(00-010203),(0,1)
+QCFG: “servicedomain”,(1,2),(0,1)
+QCFG: “roamservice”,(1,2,255),(0,1)
+QCFG: “msc”,(0-2)
+QCFG: “sgsn”,(0-2)
+QCFG: “celevel”,(0-2)
+QCFG: “pdp/duplicatechk”,(0,1)
+QCFG: “iotopmode”,(0-2)
+QCFG: “nb1/bandprior”,<band_priority_seq>
+QCFG: “psm/urc”,(0,1)
+QCFG: “ledmode”,(0,1,3)
+QCFG:: “gpio”,(1-3),[,[,,]/[][,]]

+QCFG: “airplanecontrol”,(0,1)
+QCFG: “urc/ri/ring”,(“off”,“pulse”,“always”,“auto”,“wave”),(1-2000),(1-10000),)
+QCFG: “urc/ri/smsincoming”,(“off”,“pulse”,“always”),(1-2000),(1-5)
+QCFG: “urc/ri/other”,(“off”,“pulse”),(1-2000),(1-5)
+QCFG: “risignaltype”,(“respective”,“physical”)
+QCFG: “urc/delay”,(0,1)
+QCFG: “cmux/urcport”,(0-4)
+QCFG: “ims”,(0-2)
+QCFG: “apready”,(0,1),(0,1),(100-3000)
+QCFG: “nccconf”,(0-1FF)
+QCFG: “psm/enter”,(0,1)
+QCFG: “apn/display”,(0,1)
+QCFG: “snrscan”,(0-2)