BG950A SIM registration fails

BG950A module not able to register SIM and connect to network.

The SIM is activated and works on a mobile phone. But the BG950A could not register the SIM. Is there anything else that needs to be configured from the BG950A?

You need to configure the APN corresponding to the SIM card


  1. pls check the netscanmode and nwscanseq ,since NB network search need about 36 minutes ,if we enable NB mode ,the first time registration need waiting enough time。

  2. pls check you sim card with the operator also , IOt sim card has different permission 。

Hi Herbert,

Thank you for the suggestions. I tried setting the APN. But I receive an error while activating the PDP

Looks like the APN was configured as per my command.

Hi Stephen,

Looks like the mode is set to LTE band. But still does not go through with the registration.

based on your AT log , you have register catm network successfully , stat=5 means that sim card is roaming card.

Hi Stephen,

Thank you, the additional info. I am aware of the status, and it is registering the SIM but still not completely go through with the registration. Registering/connecting to the network fails, because if you see in my screenshot below, it fails to register to GPRS. AT+CGREG? throws an error

AT+CGPADDR //If the current module can obtain an IP address, the network has been registered successfully

Hi Herbert,

Thank you. In that case looks like my SIM is registered to the LTE network. But why is the PDP activation failing after setting APN using PDP context? Do you have an idea for this?

Also once the PDP context is set what is difference between activating it using AT+CGACT and AT+QIACT. Is AT+QIACT specific to TCP/IP?

In general, I am looking to start a UDP service and send data to a remote IP.