BG950A-GL AT command not responding

I am using BG953A chip in a project. Currently can see the module is responding on main serial port with “RDY” after reset. However, it always responding with only “+”(decimal 43) no matter what AT commands I sent to it. Currently tried “ATI\r\n”, “AT\r\n”, “AT+CGMI\r\n”.

Also tried just sending “+++” and the module is responding with “+” as well.

BTW, I am sending AT command as a character array from stm32 serial port. Is there any special format I need to use?

Any advice or suggestions are much appreciated. Thanks in advance.

Correction: It seems it will only reply with “+” the first time. No more response will be received no matter what AT command I sent later.

AT commands never include a “\n” character. The responses to AT commands do, however.

They are terminated by a single character, which is “\r” by default.

The AT command termination character is stored in the modem’s S3 register, and its decimal value can be read using ATS3?

Thanks @snowgum for your reply. I did try to send the command with just “\r” and the response is the same.

Are you saying that you get only a “+” character from the first AT command, and nothing at all from subsequent AT commands?

In that case:

Are you using the correct serial port?

Is the baud rate and character framing set the same on both devices?

Yes, only once from the first command.

Serial is set to 115200 8bits no parity. I think the serial is working since I can get “\r\nRDY\r\n\r\n” after a reset.

Update: Tried to boot up from usb interface. Opened QCOMM V1.6 and AT commands are not working here either. See pic attached.

It seems I am in the bootloader. Any procedure I need to follow to get AT command working here? Thanks.

I’ve put an logic analyser on the serial bus and here is what I’ve got after resetting BG953A:

\0\r\nRDY\r\n\r\n+CFUN: 1\r\n\r\n+CPIN: READY\r\n\r\n+QUSIM: 1\r\n\r\n+QIND: SMS DONE\r\n\r\nAPP RDY\r\n

I guess the “+” I received before is just part of the above response. So I waited for the whole process to finish and
then send "ATI\r". But still got no response.

Does the chip need to be configured somehow to accept AT commands?

That modem output on startup all looks fairly standard to me.

Have you checked the serial connections and wiring for continuity?

I’m at a loss to suggest anything else to try.

Sorted. Turned out that PON_TRIG pin need to be high to enable UART comm on this chip.

1 Like