BG95-M6 does not enumerate on USB after FW update


I got latest FW from FAE and tried to update BG95-M6 Ta-E board on EVK via USB connected to Ubuntu.
The updated went well with confirmation in the log, however after module power cycle USB looks dead (no enumeration), neither blue LED is flashing (nw ).
I could still force module in USB Boot mode by shortcuting est points. In that case it enumerates as it should with Qualcomm device.
However after repeating FW update procedure device stays dead with any FW version I’ve tried.

I saw a similar problem with another module Quectel EG91 bricked after firmware update attempt - #8 by luca

I guess that could NV memory related problem.
Could someone form Quectel share a light on problem upgrading old BG95-M6 FW to the latest BG95M6LAR02A02_01.200.01.200 ?


You can lower the DTR level after the firmware upgrade and then try USB.


I grounded DTR on TA-E during powering on board via usb, but no difference at all.
Could you please clarify, do you mean DTR test point on TA-E board or somewhere else?

You need to pull the DTR down on your debug software.

Module boots only in USB_BOOT mode, otherwise no communication on any external interface.
At what point do I have to pull DTR and on what USB device& interface on Ubuntu?