BG95-M4 cellscan and attach question

I ran into an issue with a mini PCIE BG95-M4 trying to attach to a (private) LTE-M network 1.4 Mhz on EARFCN 9885(450 Mhz, band 31)

The hardware details

[2021-01-27_18:03:13:255]SubEdition: V04

I started with a SIM on a commercial operator to see if the eMTC services were OK

[2021-01-27_17:58:18:587]+QNWINFO: “eMTC”,“20408”,“LTE BAND 20”,6400

Both latency and throughput were as expected.

I also investigated the GPS routines. Worked nicely!

Following a replaced the SIM for the band 31 one and the modem was unable to connect to the network. The SIM was taken from a functional MDM9205 chipset modem(other brand)

I then tried to perform a scan

AT+QCELLSCAN=8 which returned

Using the public SIM again I was unable to perform the scan

[2021-01-27_18:00:44:140]+QCELLSCAN: -1

After switching off the GPS by AT+QGPSEND, the scan worked again.(unfortunately not anymore within coverage of the 204-66 network)

[2021-01-27_19:27:50:505]+QCELLSCAN: “eMTC”,204,04,58B2,6300,229,1A18802,-71,-7,-50
[2021-01-27_19:27:50:505]+QCELLSCAN: “eMTC”,204,08,F551,6400,30,B1310B,-78,-13,-51
[2021-01-27_19:27:50:505]+QCELLSCAN: “eMTC”,204,04,58B2,6300,276,1876501,-86,-12,-60
[2021-01-27_19:27:50:505]+QCELLSCAN: “eMTC”,204,16,40,3700,123,4B64015,-94,-11,-69

My questions;

It looks like the modem “sticks” to the last used operator. How can I release it?

Some commands I used from the BG96 AT command reference do not work. Is any firmware update needed?

Is it correct that with a running GPS, some commands are blocked?

to erase RPLMN

pls send the below AT


OK, success!

Thank you for the assistance. As feedback some a small part of the command log

After entering the APN’s the module attached with the following details


[2021-01-29_11:27:20:386]+QNWINFO: “eMTC”,“20466”,“CDMA BC0”,9885

The only remarkable issue is the name of the band “CDMA BC0” which is actually band 31 in my case

Cellscan works as well(location the Netherlands)




[2021-01-29_11:29:00:916]+QCELLSCAN: 4

[2021-01-29_11:29:00:916]+QCELLSCAN: “eMTC”,204,04,552A,6300,310,190FD02,-69,-8,-47

[2021-01-29_11:29:00:916]+QCELLSCAN: “eMTC”,204,16,111,3700,88,3749C16,-73,-8,-51

[2021-01-29_11:29:00:916]+QCELLSCAN: “eMTC”,204,08,F93B,6400,143,25EF0C,-81,-8,-59

[2021-01-29_11:29:00:916]+QCELLSCAN: “eMTC”,204,66,1,9885,1,300,-88,-8,-72

Hardware/sw used;





[2021-01-29_11:30:11:259]SubEdition: V01

And also the IMS attachment does work(no service tested yet)


[2021-01-29_11:46:23:222]+CGCONTRDP: 1,5,“internet”,,,

[2021-01-29_11:46:23:222]+CGCONTRDP: 2,6,“ims”,,