BG95-M3 QFlash Timeout on COM Port connection attempt

Hi, i use a Quectel BG95-M3, mounted on a Nimberlink Board.
The USB COM Port (24) i use is a FTDI plugged on UART Pin, i can communicate whith the modem whitout problems, by using putty.
my actual firmware, given by AT+QGMR, is :

I would like to upgrade the embedded firmware, so i installed QFlash v6.0.
The firmware i want to install is BG95M3LAR02A03_01.014.01.014, found on this forum.

My issue is that i always have a “FAIL, Confirm dynamic com port 24 timeout(N)!” when i try to connect with QFlash.

I soldered an USB connector on the USB pin (6,7,8), installed the USB drivers (Quectel_LTE_Windows_USB_Driver_V2.1.7), so the AT interface via USB was available, i sent and received commands well via putty, but even if i used this port on QFlash, i allways had this timeout.

Is there some tricks to initiate the upgrading for this kind of modem?
Is this modem compatible with QFlash?
By the way GNSS_UART_RXD and GNSS_UART_TXD are left floating.

Thanks by advance

Upgrade needs to use the DM port, please check if this port is read out.

Hi, thank you, i tried on DM port but it failed.

i uninstalled drivers and reinstall them but now i have issues detecting the device on any COM Port, modem is not recognized in windows when USB plugged,

the AT commands gives me:
+QCFGEXT: “usb/event”,0
so USB is connected but not working (0:USB CONNECT)

+QCFGEXT: “disusb”,1 (usb enabled)

Any ides what i am doing wrong? Quectel_LTE&5G_Windows_USB_Driver_V2.2.4.zipInstall these two drivers and try again

Hi, i installed those drivers, but modem is still not detected.
AT commands regarding USB give me:



+QCFGEXT: “usb/event”,0


+QURCCFG: “urcport”,(“usbmodem”,“uart1”,“dam”)



You can check if the corresponding usb pin is drawn.

Hi, i can’t access this pin because i use a nimberlink modem, the quectel chip is soldered on, those pin are inaccessible.
The USB connector is on diy pcb board.
The main issue i face is that after installing/uninstalling drivers, why the modem is not visible anymore?
My os is Win10 Pro

Run AT+QCFGEXT= “disusb”, command 0 and try restarting the device.

Hi, finally it worked, thx!
Using the DM Port, i could upgrade to 01.014

thx again :smiley:!