BG95-M3 not Responding

Hello, i prepared custom board with reference of Quectel_BG95_Reference_Design_V1.0. i implemented to work on HTTP to send some data on server and it was working good. in between BG95-M3 stopped responding. its getting ON while i am providing PWRKEY. but NETLIGHT looks like “Flicker slowly (200ms High/1800ms Low) Network searching” status. and it does not sends APP and APP READY. also not responding to AT. i also tried to capture Debug log but shows nothing there. and then i checked to upgrade firmware but usb also shows unknown device only. i plugged Quectel_UMTS&LTE_EVB_Kit with pc it shows port well. anyone can help me? thanks.


May I know whether your problem get resolved? Per your description, it mostly seems like there was something wrong with USB or UART connection.

Best Regards,

Hello, @WillieYao-Q. No problem is not solved. but i reached more close to problem. problem is there is something wrong on BG95 Rx pin when i connect uart Tx pin which is BG95 Rx pin on another side of converter ic. it introduce some noise or fluctuations on pin. so actual data is not going to send to module.

Hi tjpre9,

I am encountering same issue with BG95 RX pin, did you get more information?
It feels like RX pin is strongly pulled up, and MCU is not able to properly drive the line low. transmitted bytes are highly inconsistent. I precise that I am using BG95 M3 dev board and I only have this issue with external MCU, communication through COM port to a PC is fine.

Could we have a feedback from Quectel here?

Best regards

Hello, @Remi_Chaudet.
Actually i had another custom board. i am using that right now and that is working. i am not using that board which had problem. in this new module i made change is that earlier i changed and saved Baud rate 9600 (not changing all the time using AT Command) and right now 115200 (Which is default). and i also had problem with FTDI but that was problem with cable length as level converter is not much good with long cables.

we are encountering similar issues in the moment. We do have professional build prototypes and we do have different behaviour due to power up / power down sequence using pwrkey line.

  • 1st prototype is working as expected and we can power up and power down the modem just like expected.
  • 2nd prototype is working on power up of the complete device also as expected, but if we power down the modem by pulling pwrkey for 750ms it happens in every 3rd or 4th case the modem doesn’t power up correctly after pullng down pwrkey for 750ms again.

The effect is similar as described above. If everything is working well we do see expected signals on RX and TX. If the “hang up” happens we do see only high level on RX and TX. We are using direct connection from 1.8V MCU GPIOs with 115k2 Baud.

Is there a workaround and a technical explanation? On the eval boards we don’t see this issue.

Best regards,

1 Like