BG95-M2 RF FTM Reboot problem

Hello Everyone,

I am trying to implement RF FTM application in BG95-M2 .

here is my commands:

AT+CFUN=1,1 // reboot

AT+QRFTEST=“LTE BAND20”,24350,“ON”,50,1

if you compare the my both log image, when i dont use AT+CFUN=1,1 to reboot the modem, everything works fine but with AT+CFUN=1,1 i alwys get error.
can anyone guide me on this one ?


Have you disabled TESTMODE ?

No I have not disabled test mode?
I just run AT+QRFTESTMODE=1 and then reboot modem using AT+CFUN=1,1
but if i checked after running this two commaand
AT+QRFTESTMODE? will always gives +QRFTESTMODE:0

but without reboot (AT+CFUN=1,1) it gives +QRFTESTMODE:1

The command AT+QRFTESTMODE=1 will be restored after AT+CFUN=1,1 reboot modem.

No for me after reboot AT+QRFTESTMODE always gives 0

Yes, you could not to cfun=1,1 after you enabled FTM command.

but here usermanual say it is recommanded to reboot the module after entering FTM.
thats why i am running AT+CFUN=1,1 after AT+QRFTESTMODE=1.

Have you connect USB port?

its required to disconnect USB. or you can disable this driver:

I am not connected to USB port.
I have conncted to main COM uart.

can you check AT+CFUN? command response?

AT+CFUN? gives +CFUN:1

that’s not correct, should +CFUN: 5
And in latest AN document, this command take effect immediately.

this is my AT command log.

I dont understand why it always exit FTM mode after i reboot .