BG95 Linux drivers

I am trying to get the BG95-M3 serial access over usb using linux but the ttyUSB is not populating. The dmesg log is as below

[ 88.401472] usb 1-1: new high-speed USB device number 5 using xhci_hcd
[ 88.554259] usb 1-1: New USB device found, idVendor=2c7c, idProduct=0700, bcdDevice= 0.00
[ 88.554263] usb 1-1: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[ 88.554266] usb 1-1: Product: Quectel LPWA Module
[ 88.554268] usb 1-1: Manufacturer: Quectel, Incorporated
[ 88.554270] usb 1-1: SerialNumber: 9f240a9b
[ 88.584686] usbcore: registered new interface driver usbserial_generic
[ 88.584691] usbserial: USB Serial support registered for generic

root@XXX-debian:/dev# uname -a
Linux XXX-debian 4.19.0-12-amd64 #1 SMP Debian 4.19.152-1 (2020-10-18) x86_64 GNU/Linux

Any help will be highly appreciated

Thanks!

Did you build their custom modules? With those installed, it “just works” for me.

I figured out the issue. It was BIOS Smart boot which was causing issue. I simply terned it off and the ttyUSB ports started populating. This issue can also be solved by installing custom modules into the kernel and rebuilding the kernel as @SeanMollet suggested.

@SeanMollet it would be in the interest of the forum if you could share the exact instruction to follow to load these modules.

Thanks!

Hello, I’m also experiencing this phenomenon. I have a Linux device with version 5.10.41-yocto-standard and it does not recognize the BG95-M3 miniPCIe that I’ve installed. @SeanMollet how do I build their custom modules?

Can you try disabling SmartBoot from your system’s BIOS and try again?

Does somebody have modules for kernel 5.14? The ones I have access to I cannot compile for kernel 5.14

@Stephen.Li-Q Do you have the updated linux drivers for 5.13/5.14?

1 Like

@markolsson @hrm I will send serial port driver for 5.13/5.14 to you.

1 Like

can you also share the drivers with me?

Ok, I will send it to you via email.

@Isaac.Wang-Q your driver compilled and at first when I plug my module there are 3 new ttyUSB* ports as expected. Unfortunatelly when I start interracting with the ports the driver crashes and the ports dissapear. If you want I could try to extract dmesg log when that happens.

Also before you sent your driver, I modified the one for kernel 5.3.1 to compile for my kernel and the result was the same. My modification was to just cast some elements to (void *) . Unfortunatelly there’s something else which has to be addressed.

Does the module have a separate power supply?

It’s definately not the PSU, because I tried using official development board. Also if I switch to Windows everithing works fine

@Isaac.Wang-Q Could you send me the serial drivers for 5.13 as well? I tried modifying the 5.3 version as I believe @hrm did, but i cannot communicate with the module over the /dev/ttyUSB2 device using minicom. It simply does not answer. I am very grateful for any help, thanks in advance!

@s5m I will send it to you via email, but maybe you need to modify the option_probe function accroding to different network card types.

1 Like

Could you please send me the serial drivers for 5.13.0-51? I’m running Ubuntu 20.04 (Focal).

Many thanks!

A corresponding patch for the mainline Linux kernel has also been submitted recently here [PATCH v3] USB: serial: option: add Quectel BG95 modem - Carl Yin(殷张成). The Linux kernel that comes with Ubuntu 20.04 should be new enough to support the ZLP flag required by the patch.

Rebuilding the option.ko module with the patch included might require less effort than integrating a vendor-maintained option driver.

Regards,
Reinhard