BG95: immediate suspend in PSM

It seems that when using PSM most operators have a minimal committed Active Time (T3324) of at least 16 seconds after the last network transmission.
This consums about 0.3C charge, which is about same as a short message&response.

Is it possible in PSM mode to immediatly force the modem and cpu to enter standby after receiving a message ack without waiting on expiring the Active Timer but still keep network registration?

I tried now to enter PSM before T3324 expires by:


But it seems this command does not behave as expected event though I didn’t send any more AT commands thereafter.
The Modem revision is: BG95-M3, Revision: BG95M3LAR02A04


You can try command AT+QCFG=“psm/enter” which will let module enter psm immediately once rrc released.

Thx for suggestion, but I tried this already and unfortunately this does not speed-up going to PSM because rrc release from network comes 16s after last transmit/receive but I would like to go to PSM immediately after transmit/receive.


Which protocol are you using?
Actually, for UDP we support RAI feature which can be faster release RRC.

Yes I’m using UDP.
I tried already using AT+QISENDEX with <RAI_info> 1 and 2 but it didn’t work:
The device still does not go to PSM after send/recevie but still after 16s when the network releases RRC.
And yes, I enabled before seding RRC reporting by AT+QCSCON=1 but never get a +QCSCON: x,x message.

According the Example in the TCP(IP) Application Note PDF it is not clear if PSM has to be enabled by AT+CPSMS=1 or something else when using AT+QISENDEX with <RAI_info> 1 or 2 .
I assumed enabling PSM has to be done so the network retains the network registration.

Ahh, for RAI feature, both need base station and UE are support. are you sure it support on you local network?
or you can collect some modem log for me to check this.

Linkin WANG

I’m not sure if the network supports RAI, I assumed it does because PSM works but you are right, this might be the point!
Unfortunately I have the BG95 connected via UART not on a Windows system so I only could send the AT command log.
Does a AT command exists which shows if RAI is supported?
To be able to check this dynamically would be fine because I use a roaming SIM which will be used while crossing different countries.


Currently we cannot check via command, only need check modem log.

Many thanks Linkin WANG for helping so much!!
I read that I can enable/disable log by AT+QCFG=“dbgctl”,0/1
But with what AT command could I transfer the log thereafter over the serial line?
(The modem is not on a windows PC)

BTW: I contacted the Operator and he said that RAI is supported.

After further digging around I found the answer on page 26 of “Quectel_BG95&BG77&BG600L_Series_TCP(IP)_Application_Note_V1.1.pdf” :

RAI (Release Assistance Indication) is introduced in 3GPP Release 14 and it is primarily a MAC layer
The RAI feature is only applicable to NB-IoT RAT. This feature allows to track predictable nature of
data traffic and requests for connection release when there is no additional data to be sent. It is
essentially a ‘fast dormancy’ feature to save battery power of the UE.

According this the BG95-M3 does not support RAI on LTE Cat M, because the BG95-M3 is 3GPP Release 14 only for Cat NB (which means Cat NB2) and for Cat M only 3GPP Release 13 (which means Cat M1) where RAI is not yet supported.

So it seems there is no chance to activate RAI on LTE-M with the BG95-M3 :frowning:
(PS: The BG95-M3 should throw an ERROR when entering ‘AT+CRAI=2,0’ if LTE-M is active which it does not!)

Regards Matthias


what is written on page 26 of “Quectel_BG95&BG77&BG600L_Series_TCP(IP)_Application_Note_V1.1.pdf” is only partly correct:
3GPP Release 13 already supports RAI but only using non-access stratum (NAS) signaling whereas 3GPP Release 14 supports RAI on AS as well. (PS: For LTE NAS is on Network Layer whreas AS is on Link Layer).

So I assume the BG95-M3 only supports RAI on Link Layer (aka Access Stratum, AS) as defined in 3GPP Release 14 and thus the module supports RAI only on Cat NB and not for Cat M.