BG77 - Unable to lock to NB-IOT

I am experimenting with NB-IoT / LTE-M using the Mikrotik KNOT, which has a BG77 onboard.
SIM card is from Norwegian operator Telenor.

Using AT+QCFG=“iotopmode”,2,1 (both NB-IOT and LTE-M) the connection establishes fine, however when I try to force it to NB-IoT using AT+QCFG=“iotopmode”,1,1 the PPP-interface acquires IP address, gateway and DNS, but it won’t let traffic through to the internet.

When the connection is running using AT+QCFG=“iotopmode”,2,1, I can see on the RouterOS INFO page that access technology from time to time changes back and forth between “LTE Cat-M1” and “EC-GSM-IoT” without me changing anything.
I want to lock it on NB-IoT in order to achieve better receive sensitivity. But how?
Throughput is no issue here, I’l only transmit av few bytes every now and then.

There are a lot of differnet names and acronyms here…is it possible that “EC-GSM-IoT” is 2G/GPRS-based IoT and not what I’m looking for?
And how can I succeed in doing what I want?

Hi Bom

Have you actived PDP via AT+QIACT=1? and what’s you APN setting?
Could you help check AT+CGDCONT?

Linkin WANG

Thank you for your reply Linkin :slight_smile:
I am using default APN “internet”

Here is output of CGDCONT query:

+CGDCONT: (1-15),"IP",,,(0-1),(0-1),(0)
+CGDCONT: (1-15),"PPP",,,(0-1),(0-1),(0)
+CGDCONT: (1-15),"IPV6",,,(0-1),(0-1),(0)
+CGDCONT: (1-15),"IPV4V6",,,(0-1),(0-1),(0)
+CGDCONT: (1-15),"Non-IP",,,(0-1),(0-1),(0)

+CGDCONT: 1,"IP","internet","",0,0,0


I don’t know the concept of PDP.
Strange thing is that the connection works in CAT-M with almost no settings…do I have to define a context and apply it to be able to get NB-IoT mode?

Hi Bom,
So now the key issue is: after successed PPP, but cannot access to inernet am i right?

Linkin WANG

Yes, when command AT+QCFG=“iotopmode”,1,1 issued via PPP init string in order to force NB-IOT, PPP appears to be up and running, but traffic (ping to for instance is blocked.
Changing to AT+QCFG=“iotopmode”,2,1 makes connection good, most of the time it says access technology LTE-M.

Are you using Linux OS or Windows?

The BG77 is onboard a Mikrotik KNOT running RouterOS 7.5, which is Linux based.

Is possible to delete default route then try again?
I have met this problem on other linux OS, and it works after i delete default route

Tried to delete the dynamically created default route and added a new static one, still no luck.

Could you please help try this ?

sudo route del defaultt

Hi Linkin,

I contacted operator Telenor and they told me that my subscription did not allow me to use NB-IOT at all…
Changed subscription for the SIM-card and now I am able to specify access technology using AT+QCFG=“iotopmode”,1,1 or AT+QCFG=“iotopmode”,0,1 as I want to :smiley:
I can easily see that now I’m on NB-IOT, as latency has rised to around 4-500 ms, compared to 60-200 ms using LTE-M. But that doesn’t matter, what I’m after is maximum receive sensitivity :wink:

Thank you very much for engaging in my problem, I appreciate that very much!

Hi Bom,

Just share you problem here or my email if there any other questions.

Linkin WANG

1 Like