BG77 Time & Almanac info seems to disappear - permanent cold start on gnss

We are using the GNSS of the BG77. We are currently turning the GNSS on to look for a position and then turning it off again. It appears as though it is losing all stored time/ date and almanac information. If we keep the GNSS on, we are concerned about power loss, but will it allow hot starts? We had assumed that the data was stored and we could have hot starts regardless of whether the unit was turned on or off.

Hi Jeremy Price,
How long did you take from acquired the ephemeris to turned off the GNSS? How about from turned off the GNSS to restart the BG77 module?
Could your device synchronize the UTC time?
If you could share the schematic would be better for us to analyse. Thanks~!

Once we received our first position we turned off GNSS, and then tried again about 6 minutes later. We did not turn off the modem, this was powered up, but we turned off GNSS.

We received a full position (correct) and time, after a cold start. However when we tried again 6 minutes later, it was not a hot start, but another cold start, taking 5 minutes to get first position.

Do you believe reducing would improve the time to get a second fix? Or putting at 0?


Hi Jeremyprice,
When you received a full position and time, what you send to the module to shutdown the GNSS function? If you just shutdown the GNSS but keep the module power on, when you restart the GNSS, it would be a hot start.
If you can receive the position and time in a few seconds(about 3-5 seconds) after you restarting GNSS function( keep modem power on), then means that the position and time have been stored.
If you receive the position and time in tens of seconds(about 30 seconds) , then means that the position and time are not stored.

pls check my report output form the BG77 GNSS
1.The last time I get the position and time and shutdown the GNSS(keep the modem power on)
2.Restart the GNSS function and re-locate.
3.Received the position and time again.
*from restart to receive the position and time, it takes me about 3 seconds.

Ok, we are using the following:
To start module:
Positions taken…
To stop module:

However it is taking 5 minutes to get the next positon.

Please can you confirm what commands you are using to get what you get.

Could u send me the log of NMEA? Let me have a look and analyse.
In addtion, how long did it takes you to receive the first position and time?
I just use AT+QGPS=1 to get the position and time, after compeleting positioning, I use AT+QGPSEND to shutdown GNSS function.

We have now sorted this, thanks for your help.

Hello Jeremyprice,

Could you please tell me what was the solution?

Thank you!

Best regards,


Anyone from Quectel could help, please? The issue is still existing:

  • we are not turning off the power of the modem
  • we only turn on and off the GNSS engine with the AT commands.
  • the modem seems to loose the information about the previous GPS fix, and it always start from cold state

We really need to solve this issue soon, otherwise we cannot use this modem in our mass product.

Best regards,