BG77 not able to connect to the network

Hello, I have a problem connecting the BG77 module to the network. When I try to connect to the Vodafone network here in the Czech Republic using the command at+cops=1,0,“Vodafone CZ”,9, nothing happens and after some time I get cme error 30. The strange thing is that if I deactivate and immediately reactivate the IoT sim on the Vodafone web platform and send an at command to connect, the device connects almost instantly within 1 second. But after some time, usually seconds or minutes, it disconnects itself again and I am again not able to connect until I do the same thing - go to Vodafone platform, deactivate the sim card and activate it again. I tried to contact the Vodafone, but they just said there is no need to activate the SIM, should be already activated and also said that there is no reset forced by their network, so it has to be problem with my device. I am attaching the at communication. Thank you very much for any help.

[2023-09-13_22:06:54:085]APP RDY



[2023-09-13_22:07:36:973]+CPIN: READY


[2023-09-13_22:07:53:530]+QCFG: “nwscanseq”,0203



[2023-09-13_22:08:27:607]+QCFG: “nwscanseq”,0302


[2023-09-13_22:08:40:943]+QCFG: “iotopmode”,1


[2023-09-13_22:08:59:854]+QCFG: “band”,0x0,0x100002000000000f0e189f,0x10004200000000090e189f





[2023-09-13_22:14:34:957]+COPS: (1,“Vodafone CZ”,“Vodafone”,“23003”,9),(0,1,2,3,4),(0,1,2)

[2023-09-13_22:14:44:430]AT+COPS=1,0,“Vodafone CZ”,9

[2023-09-13_22:16:55:973]+CME ERROR: 30

//this is after I deactivated and activated the SIM on Vodafone platform

[2023-09-13_22:19:18:811]AT+COPS=1,0,“Vodafone CZ”,9


[2023-09-13_22:19:38:337]+QPING: 0,“”,32,622,255
[2023-09-13_22:19:38:526]+QPING: 0,“”,32,190,255
[2023-09-13_22:19:39:106]+QPING: 0,“”,32,575,255
[2023-09-13_22:19:39:246]+QPING: 0,“”,32,149,255

[2023-09-13_22:19:39:246]+QPING: 0,4,4,0,149,622,384
[2023-09-13_22:22:54:180]+QIURC: “pdpdeact”,1


[2023-09-13_22:23:03:356]+QPING: 561

[2023-09-13_22:26:02:340]+QNWINFO: No Service


You have not configured the APN in that command. A valid APN is mandatory for connection on most networks.

Well, I tried AT+CGDCONT=1,“IPV4V6”,“”, but it didn´t help. The problem sadly still remains.

It maybe helped, I am not sure. I am really new to all of this, just trying to learn something. I tried to set the APN with AT+CGDCONT=1,“IP”,“" and then tried to set AT+COPS=0 and connect with AT+COPS=0,0,“Vodafone CZ”,9. After about one minute it connected with no need to deactivate and activate the SIM. Now it is still connected for about half an hour without any problem. The network haven´t kicked me out yet. Hopefully this was the solution and not just random.

I’ve always been conservative when locking to a network with +COPS, and used the numeric PLMN rather than the name.

In your case, that would be AT+COPS=1,2,"23003",9

Thank you for your help, but the problem still remains. No matter what I tried, it is still the same. I am in most cases not able to connect. It connected once in 10 attempts and then randomly disconnected.