BG600L-M3 recover stock firmware & config


I have BG600 dev board and after compiling firmware with Quectel_BG600LM3_QuecOpen_SDK_Package_V1.0.0_BETA20200417 and flashing, the AT command uart doesn’t respond. Even if I delete my appliction binary and oem_app_path.ini file there is no effect.

I tried to flash BG600LM3LAR02A04_01.002.01.002 firmware with QFLASH 5.3 and still no result.

My questions are:

  1. Why there are no freely avaliable resources for almost all quectel modules and why I cannot download the latest firmware, tools and SDK without spamming my supplier?

  2. BG600LM3LAR02A04_01.002.01.002 has multiple files and folders. I tried flashing whatever the tool permited with no effect. What files should I exactly flash to return my module to stock configuration?

  3. Why oem_app_path.ini and the firmware still persist even after successfull update of the module? Is there option to do a factory reset?

Also please provide links for newer resources if avaliable. I would also be grateful if there was freely avaliable downloads page on your site.

sorry for inconvenience .

  1. for one module , there are many different baselines and code branchs , there is no
    the best fw version can match the request of all the customer .

  2. based on the description , yes , the module seem to be the crash status , To reflash the modle ,

pls kindly download the tools from the below link :slight_smile:

  1. to remove the old fw version with the below tools

Hi again.

Is there a way to completely wipe all the primary and EFS filesystems and the whole flash in genereal?

Also could you post a link to the --newest firmware-- and to --QFlash 5.6-- (in your website the latest version is not 5.3). Also inside the firmware folder there is subfolders.

Now I can only flash the module using dam/recover/firehose. What is the purpose of the other files? Can I use them to completely overwrite the module’s NV memory?