BG 95m2 Inconsistent behaviour of AT+COPS=?

Hi
I’ve got a problem while using AT+COPS=? command. There are two things:

  • firstly when I scan the networks it doesnt show all the possible networks, however I’m able to connect to it( I know it is available)

  • after connection to the specific network at+cops=? shows only the network I’m connected to (which was unavailable in previous scan)

(09:43:57.897) at+cops=?
(09:45:55.995) +cops: (1,“T-Mobile.pl”,“TM PL”,“26002”,9),(1,“Plus”,“PLUS”,“26001”,9),(0,1,2,3,4),(0,1,2)
(09:45:56.005) OK

(09:55:16.071) at+cops=1,2,“26003”,8
(09:55:18.911) OK

(09:56:32.182) at+cops=?
(09:56:32.227) +cops: (2,“Orange”,“Orange”,“26003”,8),(0,1,2,3,4),(0,1,2
(09:56:32.227) OK

Main problem is that in first scan it doesn’t show all the possbile networks

to query the network registered currently , Pls use at+cops?

by default , This AT cmd will can all available network currently , the mode is automatic

but in your at log ,at+cops=1,2,“26003”,8 , you select mode parameter as 1 , it means that manual mode and force to lock to this operator , So the available network displayed is the operator you locked in