BC95 MQTT support

Does BC95-G support MQTT for anything other than Huawei cloud?

Thanks

hi,FooBar_BarFoo:
BC95-G also supports Aliyun,you can try.

I meant my own custom server, that is not an option?

Self-built MQTT servers can be supported

OK, good, can you give me some pointers, maybe some example.

Thanks

hi,FooBar_BarFoo:
I don’t have relevant examples, but I have tested our self-built MQTT server and module communication is normal;You can use the mqtt.fx tool to test your server, and if it works, you can communicate with the module via at commands.
Quectel_BG95&BG77&BG600L_Series_MQTT_Application_Note_V1.1.pdf (617.9 KB)

Thanks for the info.

Hi @herbert.pan-Q: I’m trying to use MQTT, and followed the example provided in the manual (BC-95 MQTT Application manual).

Here, I’m using a public broker/server - test.mosquitto.org & its port - 1883

When I’m giving the command as “AT+QMTOPEN=0,“test.mosquitto.org”,1883” to open a network, it responses as “+QMTOPEN: 0,-1”

I have checked the server using MQTT.fx, & it is working fine!

-1 : Failed to open a network

Why it is not connecting? Any other steps/settings i need to do here?

Thanks in advance!


please run the below AT Command to try it

AT+CGPADDR
AT+QIDNSCFG=8.8.8.8,8.8.4.4
AT+QDNS=0,test.mosquitto.org
AT+QMTOPEN=0,“test.mosquitto.org”,1883

Thanks for the immediate reply!

I have given the commands & the reponses are here,

It only returned as OK instead of “+QMTOPEN: 0,0” for successfull connection

Well, I think it has something to do with your IPv6 address, so I suggest you contact your SIM card provider or carrier to check whether your SIM card supports IPv6 only; If only IPv6 is supported, you need to enable the IPv4 service

Whether it will support to use MQTT only with IPv4?

Response after a period of time!

You need to verify whether your MQTT server supports IPv6

Yes! It supports IPv6.

Whether the BC95-G module need any firmware upgrade?

If so, Can you please share with us the file & the procedure to do it?

Thanks in advance!

I suggest you add IPv4 service and try again

Thanks for the reply!

I asked my SIM provider, they said it only supports IPv6.

Is there any option to work with?