BC95-G Cant connect to module-socket from server

Dear quectel-people,

I try to connect to the BC95G via socket.
everything is still fine, AT+CGPADDR returns the IP-Address of the module, I can “nping” and so on.
Then I create a TCP-Socket using
response = 1
Then I try to connect from the server (which is inside the same VPN), but no success.
When I Listen on the Server for a connection and then try
AT+NSOCO=1,,6500 a connection is established and I can send data once to the module.
But how can I make the connection the other way around, i.e. open a socket and let the server connect to the module? (I also tried DGRAM,17 = UDP instead of STREAM, 6 = TCP)
Thx in advance

you’re very great!
I suggest you first execute the following “AT Command”:


Then run your process again, and if there is an error, I suggest you upload your output;Based on your description, do you plan to have the server send data to the module?Normally, the module sends data to the server initially, and then the server returns the response data.The server cannot initiatively send data to the module actively because the module’s IP address is network-dependent and unknown.

Hi herbert.pan
Thx. I tried your suggestion and it worked!