BC66NB - data isn't received from server

I am using BC66NB module. The communication to our server is OK. But sometimes I have a problem with receiving data from our server. Sometimes the data is in the module in few seconds, sometimes it takes several minutes (ca. 5 min.) and sometimes the data doesn’t receive at all (I have to send data to the server and then I receive the data).
I have tried to disable all sleep modes (AT+QSCLK=0, AT+CPSMS=0,“11100000”,“11100000”), but it didn’t help.
We are using UDP protocol.

Probably the problem isn’t on our server.

Thank you very much for your help.

Hi Jiri
From your description of the phenomenon, I can only give you a general analysis direction. Specifically, we need to see the interaction between the bottom layer and the network. Please provide the corresponding debug log.

You can download the log tool and useguide from the following link.Thanks!

The possible causes are as follows:
1、Firstly,You have only turned off the PSM mode of the module but not the e-DRX. It is possible that there is downlink data after the module enters the e-DRX. If the e-DRX timeout is required, the module can receive the downlink data, resulting in a large downlink delay.
2、Secondly,it may also be due to the poor network environment on site, resulting in the loss of downlink data or large network delay.

1、AT+CEDRXS=0,(AT+QSCLK=0, AT+CPSMS=0),Close e-DRX and PSM ,then try again.
2、By changing the APN of the operator’s SIM card to turn off the PSM and edrx functions, the real-time downlink demand can be realized.
3、Please provide the specific debug log and data interaction time point. Let’s confirm the specific reason.


  • Bad signal, bad antena …
  • Old firmware … Use firmware …07… up, change DNS servers to “yours” or global,

Hi Wizlo
You are using UDP protocol, and DNS resolution has nothing to do with it.

firmware version …05… use China DNS which doesn’t work for the world and makes long pauses in minutes
in this version and old this DNS can not be changed

Hi Wizlo

BC66NAR01A05firmware version does not support DNS modifications.
You can upgrade to the latest version, the default DNS is,

Owing to the firmware you used is too old, it have a little bug, and new firmware already fixed, so please upgrade it to leastest frimware to have a try.The following link is the firmware package:


Hi Abner,

thank you very much.

I tried to turn off the e-DRX. And it helped. Now it is much better, it is almost perfect. The information from server is lost in ca. 5 %.

I am sorry, I also tried to prepare a log with the M2625 NBIOT tool. But I don’t know how to start with it. I guess that a log with UART communication between the module and the CPU isn’t enough, right? I don’t have any other tool (for example a development kit with BC66 and so on). Is it possible to get the log, which you need, without any other hardware tool?

Thank you very much.

Hi Abner,

thank you.

I used version 06. I updated to version 07 yesterday. But I don’t see much difference. Still the information is lost sometimes.

Hi Abner,
I personally have no problems with this module…

Jiri, what is your band ( frequency ) at 900 MHz module work fine
but for 1800 MHz you need good antena

Hi Jiri
Owing to you use UDP to send the data, as you know that UDP is unreliable, so package lost is normal. In order to avoid it happened, it is better to design retransmit mechanism in your MCU code.
By the way, NBIOT tool should connect the module DBG UART port and AUX UART port at the same time.

Hi Abner
I wanted to say that the lower frequency (900) module works much better that (1800)

Hi WizIO
Yes you are right!

Hi jiri.paar,

I am working with the BC66 and OpenCPU with the FW revision: BC66NBR01A10

I’ve noticed these Rx failures from the revision BC66NBR01A06.

I am using UDP and the error rate for RX is around 8-5%. We know that with UDP there is a possibility of missing some packets, but 5-8% is too much. I think something is wrong. I am using the EVB BC26-TE-B_V2.1 with the BC66 module, so it is not an antenna issue.

Best regards.

Hi Oscargomezf
I have communicated with you by mail.

Hi Abner,

Thank you very much for your quick reply and help.

I didn’t receive any email. Would you mind checking that, please?

Best regards.

Hello WizIO,
I am sorry for my delay answer.

I have tested more bands. I have found on the internet that the global bands are 3,8 and 20. The module is able to communicate in band 20, this band is ca. 800MHz.

must be 2-3 km radius from the cell
where is “your” band - ask your provider

in office I am of ~1.5 km from the cell ( 900MHz ) and I get from Olimex “antena” -87dbm from the room

Hello oscargomezf,
I can understand that the UDP packets can be lost. The problem is that if module starts to not receive the packets, then no packets are received at all (sometimes). I have to send a message to server, then the communication works again.
Where could I find the FW revision BC66NBR01A10? Maybe it could help me a little bit. Thank you very much.

Hi Jiri,

You should have to ask to your Quectel provider for the new FW.

Best regards.