BC66NB-04-STD Network Problem


I have a PCB that has BC66 on it. I’ve done the firmware upgrade, I can use AT commands and get responses. My problem lies with the network part which I’m not that familiar with. Before this module I’ve used M95 and MC60 modules. On those modules, I used to set my APN with AT+QIREGAPP and AT+CGDCONT after those I would go on to AT+CGACT=1,1 and if I do remember correctly that was it. AT+CREG would return 1 as AT+CGATT then I would go on to use MQTT commands which I aim to do with this module as well.

My steps with this module were;

  1. Upgrade firmware
  2. See that NETLIGHT was always OFF, read that(hardware design) it was due to DRX/eDRX/PSM modes so I turn those off with AT+CPSMS=0 and AT+CEDRXS=0 before setting AT+QLEDMODE to 1. Now it’s always in search mode.
  3. I couldn’t find AT+QIREGAPP in this module so I’ve just set AT+CGDCONT=1,“IP”,“APNname”
  4. Tried AT+CGACT=1,1 got “No Carrier” after a brief pause
  5. AT+CEREG returns 0,2 and AT+CSQ returns 0,0 but I’m in a place with good coverage and my other modules returns at least 15.
  6. After restarting the module my AT+CGDCONT? and AT+CGPADDR? returns just OK without a value even after I set AT+CGDCONT before restart.
  7. ATI returns;
    Revision: BC66NBR01A10

I think I’m missing some steps with this module, I’ve read the documents but couldn’t figure it out. A little help would be much appreciated.

Best regards, Akif.

UPDATE: turns out my SIM card does not support NB-IoT. I’ll get a new one and try it again

Nobody replied but I’m still looking for a solution.
After retrying with the correct SIM card I still can’t connect to network nothing realy changed. AT+CSQ still returns 0. I’m in an area with good coverage, I have a high gain 4-band antenna, my PCB trace is no where near perfect but I don’t think it’s that bad to result a 0 signal strength. Does anybody have an idea about my problem here?
I’ve upgraded the firmware again it’s now BC66NBR01A11 but other than that everything is the same.

Bad antenna
Bad signal ( far from cell )
Config and store APN


//Enable scrambling function (required once)

//Set default APN for PDP context (required once)
//This make auto connect to provider
AT*MCGDEFCONT="IP","apn_from_operator" <---------- edit this

//Reboot the module

Thank you for your reply.
I bought 2 new antennas this week I don’t think antenna is the problem.
I’m in an area with good coverage my other modules (M95 and MC60) returns 15 and 19 inside, 20+ outside.
BC66 returns 0 with or without antenna inside and outside. I have no shorts or opens in my antenna trace the desing isn’t good but I don’t know if it warrants a 0 just because of the trace. Below is the picture of the trace;

Does APN affects signal strength? I thought AT+CSQ would return something even without setting an APN, reason for my asking is my provider made a mistake related to APN on another project so my APN might be wrong even though they said countless times there were no problems this time.

I have set AT+CFUN=1 and AT+QCGDEFCONT before but I saw AT+QSPCHSC=1 first time. I did that too now but still no change

NO, The APN is authorization to using Narrow Band from the provider

for CSQ need connection to cell

look CEREG answer 1,5 ok, 0 no net, 2 searching
for the first connection need aprox a minute (searching all bands) next connection is aprox 5 seconds

Yeah my CEREG is always 2 sometimes it becomes 0 and 2 again I’m guessing that’s because my signal strength is 0 since my provider says my SIM and APN is good to go. However I can’t figure out why the signal strength is 0, I am gonna design another PCB but before doing I want to pinpoint the failure. I was hoping there was a command I missed or something software related.

0, 2, 0, 2 … 1
no net, searching… connected

you are far from the cell… try external antenna or change position ( the NarrowBand is not activated everywhere, as provider beginning )
for 900 MHz cell radius is aprox 2km
for 1800 aprox 1km

Then, I will try to learn if I’m near a source or I’ll move to some other location.

Hi Makif
Is the problem solved?

Hi Abner,
Sorry for the late reply. The problem still exists. However we are thinking that it’s related to SIM card and we are still trying to solve that. You can consider the thread closed though.