BC66 PPP connection not working

I am tryiong to establish PPP connection between my laptop and BC66-DVK. I have been following instructions presented in Quectel_BC66&BC66-NA_PPP_Application_Note_V1.0.
While trying to create dial-up connection, instead of error code 692 came. In the instructions error code is 633. I still tried to set up connection anyway.
Next abnormal pop up window came when trying to change security properties of the dial-up connection:

I still manged to set up properties as they should be set and then tried to dial again. Same error as earlier raised (Erroe code 692: There was a hardware failure in the modem (or other connected device)

Any ideas where the problem might be or any tips how to debug this further would be appreciated?

Hi Niko
Pop-ups can be ignored.
Error 692 please confirm the Ctrl Flow of the serial port.
Please follow the documentation process strictly.


While trying to establish PPP-connection, at port was set to modem port with command AT+EPORT=1,connl,4. How can I set AT port back to default, since I am no longer using PPP?

Hi Niko
AT+eport=1,connl,0 Set as default.