BC66 LW M2M in PSK mode fails

I’m doing a project where I’m using the LWm2m functionality of the BC66
I using the leshan test server from eclipse. And I can connect fine to the BootStrap server, when not using PSK.
But when I use PSK I get an error 1, when connecting.

Do youguys have some ideas?

Anyways heres my log:

BC66 TX: AT+QLWCONFIG=0,“leshan.eclipseprojects.io”,5684,“A00001867997034736776”,600,0,“A00001867997034736776”,“10203040”
BC66 RX: OK
Found answer:OK
BC66 RX: +CEREG: 1
CEREG code: 1
BC66 RX: +IP: 10.81.218.161
BC66 TX: AT+QLWREG
BC66 RX: OK
Found answer:OK
BC66 RX: +QLWREG: 1

NB: I’m using FW version BC66NBR01A11, is that the latest?

Morten, Denmark

hi,mortencomadan:
I suggest you convert PSK to HEX format and try again!

Hello. It should already be in hex, so please elaborate on what you mean :slight_smile:

hi,mortencomadan:
Please try again:

AT+QLWCONFIG=0,“leshan.eclipseprojects.io”,5684,“A00001867997034736776”,600,0,“A00001867997034736776”,“3130323033303430”

Hi Herbert Pan.

I should be in hex already, but I tried your suggestion but it still doesnt work.
Do you have more ideas I could try

Morten

hi,mortencomadan:
Please change the domain name(leshan.eclipseprojects.io) to IP and try again.
OR

AT+QIDNSCFG=,[,]
such as:
AT+QIDNSCFG=1,8.8.8.8,8.8.4.4

I tried both those things.
I still get +QLWREG: 1 when connecting.

Hi Mortencomadan,

Eclipse Leshan Bootstrap server is at port 5784, not 5684, this is your error. Your initial key was correct.
I tried similar config like yours and was successful:

12:29:33: AT+QLWCONFIG=1,“leshan.eclipseprojects.io”,“5784”,“A00001867997034736777”,60,0,“A00001867997034736777”,“10203040”
12:29:33: OK
12:29:33: AT+QLWREG
12:29:34: OK
12:29:42: +QLWURC: “lifetime_changed”,300
12:29:42: +QLWURC: “min_period_changed”,1
12:29:42: +QLWURC: “binding_changed”,U
12:29:44: +QLWURC: “bs_finished”
12:29:48: +QLWREG: 0

image

Please ensure that you have add clients configuration in the bootstrap server.
If you set your client to use PSK, please also ensure you have add security information in your leshan server.

P/S: Quectel support while attentive oftentimes not very helpful at all.

Thank you for your help. The 5684 port was because i was trying just normal PSK without the bootstrap. And neither works.
I’ve tried writing the config just like you did:
AT+QLWCONFIG=1,“leshan.eclipseprojects.io”,“5784”,“A00001867997034736777”,60,0,“A00001867997034736777”,“10203040”
But it still gives me a +QLWREG: 1

Do you have any idea on what i can try?

The key thing is that it works flawlessly without PSK.

Morten Hedegaard, Denmark

Hi Morten,

I just tried it and it still works:

14:15:07: AT+QLWCONFIG=1,“leshan.eclipseprojects.io”,“5784”,“A00001867997034736777”,60,0,“A00001867997034736777”,“10203040”
14:15:07: OK
14:15:07: AT+QLWREG
14:15:08: OK
14:15:16: +QLWURC: “lifetime_changed”,300
14:15:16: +QLWURC: “min_period_changed”,1
14:15:16: +QLWURC: “binding_changed”,U
14:15:17: +QLWURC: “bs_finished”
14:15:21: +QLWREG: 0

Perhaps your firmware is outdated? Following is my firmware:

14:14:54: AT+QGMR
14:14:54: BC66NBR03A03_01.001.01.001

Thanks for the quick reply.

My firmware is BC66NBR01A11
So maybe its outdate, im noticing a 03 in yours after the BR.

I’ve always wondered where you find the latest firmware for these devices?

Normally just directly email the local/regional FAE.

Maybe @herbert.pan-Q can help provide you with latest firmware.

I think i’ve done that in the past. But havent really gotten any thing.
where did you get yours from?

Lets hope herbert can provide some information.

I got the newest version, which seems to be the same as the one you use.
and it looks like it working. So that’s wonderful news. Thanks for the help.

1 Like