BC66, disable the use of eDRX

I’m currently using the BC66 modules to provide NBIoT functionality to one of my company’s products.

Our intent is to configure our modules to operate in Power Saving Mode (PSM) without Extended Discontinuous Reception (eDRX) as this is a battery powered device in which we are observing an excessive power consumption. We have contacted our network provider who confirms that we are requesting eDRX to the network with this very small cycle length, which is not what we want. Instead of the 1 to 4 communication sessions per day there are observing several thousands (average of, 14000). Most of these communications are wake-ups for the paging time window (which our microprocessor isn’t using because it is also in deep sleep).

We have verified that the modules we have are shipped with a eDRX default configuration, which we are not capable of de-activating. On our configuration we are using:
AT+CEDRXS=0
which always yields the “OK” answer.
AT+CEDRXRDP
gives 0. However, AT+CEDRXS?
Always answers +CEDRXS: 5,“0000”

This answer isn’t foreseen in the manual version I have, however I’m led to believe this means we are in E-UTRAN (NB-S1 mode) and the <requested_eDRX_value> is setted to 5.12 seconds

Furthermore, we have experimented with the "AT+QEDRXCFG= "command using the same parameters as well as using both “AT+QEDRXCFG=” and “AT+CEDRXS=” to no avail.

Could someone please help me find what is the correct procedure to de-activate eDRX?.

All you have to do is execute the following AT Command:

AT+CEDRXS=0,5
AT+CEDRXRDP //only return 0

Regardless of executing AT+CEDRXS=0,5 or my original AT+CEDRXS=0 when I do
AT+CEDRXS? I always get this answer +CEDRXS: 5,“0000”

Per the 3GPP TS 24.008 specification, doesn’t this imply a 5.12 seconds for the eDRX cycle length (and doesn’t the 5 mean its on?)

No, you can measure the state by power consumption instrument, your query value may be the default value

Sorry but I will have to disagree.
We are measuring consumption on our deployed units and they’re consuming battery as if they were always on. Furthermore, our NBIoT service provider is giving us the information that we are requesting eDRX from the network with the 5.20 sec interval.

Is it possible I’m missing something else in the configuration? Are there any AT commands that reset the eDRX as a side effect?

Does your device need eDRX or not? If not, turn off eDRX on the mode-side. The network supports eDRX but it does not work

I don’t want eDRX only simple PSM.
The is Power Saving with eDRX and without eDRX and I want power saving without eDRX.

The issue is,
I do “AT+CEDRXS=0,5” I get “OK”
I do “AT+CEDRXRDP” and it returns “0”
If I do “AT+CEDRXS=?” i get +CEDRXS: 5,“0000”

The power consumption is consistent with the eDRX being on and if I ask my NBIoT service provider they are giving us the information that we are requesting eDRX from the network with the 5.20 sec interval.

The module is still on despite the fact I issued the eDRX off command. I’m trying to understand why is that and how to fix it so that it doesn’t.

It has instructed you to turn off eDRX, otherwise you cannot turn on the PSM module