BC66 broken - does not respond


I am using a BC66 module on a custom PCB, which was working well, I could communicate with the module, send data, it had full functionality. The custom PCB had no problems so far. The module has A10 filmware.

I have made a test setup, with a battery and a sensor to measure data and send it every 5 minutes to a remote server. I had done tests like this and I hadn’t encountered any problem before, but those tests were much shorter. (like running it only for a few hours)

Now after 2 days, the BC66 stopped responding, and it is currently broken. The module had not been touched in this period.
I have got an LED on my PCB for netlight, and I enabled the netlight functionality. Now the netlight LED is fully on (driven by an NPN transistor) which indicates that the BC66’s netligh pin is fully active.
It does not respond to the PWR enable, RESET, PSM_EINT signals, I have tried pressing them for a while, also in different combinations, without any success. I have also removed the battery, waited for a while, then tried over several times. I have discharged all of the capacitors on the power line before repowering. The board has an MCU onto it, I have disconnected the UART lines, but it did not help.

I tested these signals on the pins, directly. The power enable signal was around 3.2 V with 3.3V supply, and went to 0 when pulled down the line, according to the HW guide, this should be nominal. The reset signal interestingly is only at 1.3 V when idling, and pulls down to 0 V. When I activate the reset, other voltages, like the netlight output goes down too. The netlight output is also around 1.3 V. The 1.8V regulator output was sitting around 1 V.
These voltage readings were unchanged despite enabling power, or doing a power cycle, etc.
When the module failed, the ambient temperature was around 5°C. The module was in a protected area, in a protected enclosing, so it was not exposed to rain/sunlight, etc. Also the box had a bag of silica gel for humidity control. Also I brought the module inside, tested again after warming up, but nothing changed.

With a simple power consumption monitor, I have noticed when I power up the module, it draws around 2.2 mA, after enabling the power, it goes up, and starts to oscillate between 3.4 and 7.7 mA. (The MCU was active during this test, so about 0.5-1 mA is MCU consumption.) ( I estimate the oscillation frequency around 17 kHz.

For the PCB, I have followed the reference design, placed ESD diodes at the human-interaction areas. It is supplied by a 3.6V LiSoCl2 battery, regulated by a buck converter to 3.3V. So the voltage must have not exceeded any limitations. Also the battery used is a bit overkill, a fresh 19 Ah, it can supply currents around 400 mA, also I have around 1100 uF on the power line. I have tested the module with less current-capable supplies, and was working fine, so that should not be the problem.

According to the observations, the problem could be something related to the power enabling, because it does not output 1.8V, also the reset high sits around 1.3 V, but this is just a guess, I am not sure.

Any ideas what should I investigate more, or what could have caused the problem? Do you think the module is permanently broken? Any recommendations how should I try to fix it?
I have more test PCBs, but currently I don’t have access them for a few days. The whole hardware was working absolutely fine, without any problems whatsoever, so this sudden, seemingly permanent broke really worries me.
Or could have the module been faulty, or damaged during the assembly process, and after a long term usage, it eventually broke permanently?

Thanks for your answers in advance.

Hi Laszlo
According to your description, we are not sure what the reason is. We need to check the schematic diagram and PCB of the device to determine whether the hardware has such hidden dangers.
Can you provide the PCB and schematic diagram of the peripheral of the lower module?

1 Like

You should double check RESET and PWR line. Maybe they are held low for some weird reason (defect tact switch). This could explain the power consumption.

1 Like

Simply re-flash the module - if work,
check the functions that record in NVDM ( eeprom )

1 Like


Thank you for your responses.
I have checked the solder joints, and they were tarnished. They were hand soldered with a bad quality flux, so maybe that caused the problem. I resoldered the pins with a better quality flux, after that the 1.8v supply was nominal, also the module’s behaviour became more nominal (not perfect). After going over some joints again, and connecting back the MCU lines - it started to work again.
Probably the joints were bad quality due to the bad flux, (which also left some residue, which was really hard to clean off, and now I checked, the flux used was slightly conductive…), now with the better quality one, the joints look shiny, as they should, and I did some excessive cleaning after the process too. Probably some of the bad joints broke up over time, or developed more resistance, that could have caused the problem.
Thanks WizIO too, I thought about it, but the module was totally unresponsive to any normal UART command, so I thought the flashing would not work… as turned out it was a direct hardware problem.

Thank you for your help, and the lesson learnt, use good quality flux!