Band Lock Band66 completely broken

I have literally tried everything. This is either a faulty board or the advertising lied completely. I’m looking for a closed network that operates on band66. My SIM is functional, I am completely unable to bandlock the modem.

[2023-05-16 13:40:11:397_R:] OK
[2023-05-16 13:41:54:043_S:] at+qcfg=“band”,0,20000000000000000,0
[2023-05-16 13:41:54:098_R:] at+qcfg=“band”,0,20000000000000000,0
[2023-05-16 13:41:54:098_R:] ERROR
[2023-05-16 13:44:19:379_S:] at+qcfg=“nwscanmode”,3
[2023-05-16 13:44:19:440_R:] at+qcfg=“nwscanmode”,3
[2023-05-16 13:44:19:440_R:] OK
[2023-05-16 13:45:14:083_S:] AT+QCFG=“band”,0,20000000000000000
[2023-05-16 13:45:14:140_R:] AT+QCFG=“band”,0,20000000000000000
[2023-05-16 13:45:14:140_R:] ERROR
[2023-05-16 13:45:19:627_S:] AT+QCFG=“band”,0,20000000000000000,0
[2023-05-16 13:45:19:689_R:] AT+QCFG=“band”,0,20000000000000000,0
[2023-05-16 13:45:19:689_R:] ERROR

I have tried to scan for networks. I have used multiple operating systems and drivers. Tell me I’m not crazy.

What’s your current band set? What does AT+QCFG="band" return?

Can I ask you what specific frequency band is used by B66 there? I see EC25-AFX support for B66 band as screenshot.
In addition, is it normal for this module to register with other frequency network?