AT+QMTOPEN return 0,3 and 0,4 even if the AT command for PDP config was set before


i work on a project, in which i need to use an m95fa to send alert by sms and on the MQTT broker, when the power of an acid 12 V battery ( that power our system ) is low, it’s ok to send sms to my phone we have an MQTT broker, and i need to log to it for the data, so in my program i have few AT commands, but the main AT commands for MQTT that i use are the following :



Bellow there is part of my program (writed in python ) for at commands :

Bellow this is the result of all the AT commands that i use


As you can see, QMTOPEN retrun 0,3 and 0,4

Does anybody know how to fix this issue ?

Thanks in advance

Hello, it looks like your context is not active, AT+QIACT returns failure, AT+QISTAT returns “TP IND”

This means that the process of activating GPRS/CSD context is appropriate, please activate the context successfully before connecting MQTT’s network

Also, please send the “ATI” command to get the current firmware version of the program and provide it to me, this will help me lock down the problem

Hi,I have tried to connect to your MQTT server, and it can be connected. I think your problem should be that PDN is not activated, so you can use AT+CGATT? The command queries the status to see whether the reply is “+CGATT: 1”, which means that GPRS is attached successfully; If this fails, use "AT+CREG? Command query whether search network success, reply “+CREG: 0,1” represents success, good luck to you

Ok, i’ve tried AT+CGATT? it returns +CGATT : 1 but AT+CREG? return 0,5.

5 means roaming. Check whether your module can connect to the network properly(you can try to to connect to TCP/UDP and see if you can send data), send messages or make calls.