AT command not working properly

hi i am using mc60
i used this AT+QPCMD and successfully uploaded file but after that i am using “+++”, or any other command nothing is working. i need to restart my mc60 .

so i want to know how to resolve it

i am using AT+QPCMD in call state.i am able to here the audio sent by me in my mobile but after that i am unable to exit

Usually when the three-character sequence +++ is used to transition a modem from data mode to command mode those three “+” characters need to be sent in quick succession with silence either side.

So no <carriage-return> or other termination character after the +++

after playing audio i want to come out of that mode .
so i used AT+QPCMD=0 and other commands but nothing is working
how to exit that mode in mc60

Are you in data mode or command mode at that point?

i am in data mode.
to come from data mode to command mode . i am using +++ but no response in Qcom.
then i tried AT+QPCMD=0,still no response from Qcom.

so what is the right command to exit from data mode in quectel mc60.

How are you entering the “+++” string?

You’ve got to suppress the <carriage-return> character used at the end of AT commands.

AT commands need the <carriage-return> to work. The “+++” is not a command, it’s just a three-character string which requires a guard time before and after.

why dont you give a simple answer.
i simply want to exit data mode in mc60

so what is the at right at command ?

The AT command to switch from data mode to command mode is ATO (that’s the letter “O”). But you’ve got to go through the “+++” mechanism first.

I’m not convinced the ATO command is necessary in this case.

As with all modems from the last 35+ years, you simply put “+++” into the data stream. Not as a command but as a string of three “+” characters, with a couple of seconds “quiet time” before and after.

How are you attempting to introduce “+++” into the data stream? It’s all in the technique.

Why don’t you answer my question about how you’re attempting to send “+++”?

That’s about as simple as I can make it.

That was faulty memory on my part, and I need to correct it.

When a data port has been switched to command mode using the “+++” mechanism, it can be switched back into data mode using the AT command ATO

There is no command to switch from data mode to command mode. A port in data mode does not accept commands.

I stress again that “+++” is not a command. It is a three character string which needs a guard time (AKA guard interval) to work.

i will try and i will let u know what happened

i used +++
nothing happened

Clear “Send With Enter” checkbox before sending +++ or try another simpler terminal program like putty. It is important to not send any other character or code after the last + within a guard interval.
One of the explanations that could be found on Internet:

When connected and in Data Mode the Escape Sequence will return to Command Mode . The +++ Escape Sequence is only recognised if surrounded by a guard interval of 1 second ie. there must be a one second pause before and after entering +++ or it will not be recognised but simply treated as part of the data stream

i cleared the data.
i send “+++” after 5 seconds .
still no response

Please read my answer carefully, it was no recommendation to clear “the data”.

u want me to clear the data right ?
and i cleared it .
am i wrong

i understand
i got it

this is what happened
i mean
AT command is not responding
unable to make a call

You need to avoid Enter for +++ sequence only, you still need it for the regular commands.

thanks for your help.
i succeeded in doing that
thanks a lot
i read your message carefully
thanks a lot

i dont find at commands to store audio file to flash memory in mc60.
if you know please help me .

my goal is to store my audio file in mc60 flash memory and paly it