AT command GPRS

Hi, I’m having trouble with the GPRS connection. I use windows 10 api to communicate with the modem. After the attach phase, pdp context, I am assigned an IP address. From here I call the number and receive nothing. When I ping for example google, the packets are lost. Can you explain what I can do for the data connection to be successful?
this is the code i ran:

AT+CGDCONT = 1,“IP”,“”
ATD* 99** *1#

and then i try the ping on windows propt cmd

sorry but the logs are in italian language
Thank you much

Hi Star2909:
Could you please tell me the software version of your module?(Please use ATI to check).
You need to create a PPP dial-up on Win10 system and then use ATD*99# to dial.
You can refer to the attached steps.PPP.pdf (167.1 KB)

Hello Winnie,
i use the modem EC25.
I confirm that I first established a PPP connection and then I used the windows 10 api to send the AT commands.

From the log I only see the outgoing requests from the PC to the phone, but never uplink traffic.
I can’t open web pages or ping.
if I see the flowchart of the file you sent me, it hangs in the data transmission part.
Why do i have to dial this number ATD * 99 # to call? shouldn’t I also enter the pdp context that I created and therefore ATD* 99** *1# ?
because during the configuration of the modem in the AT commands I had entered the command
AT+CGDCONT = 1,“IP”,“”

ATD* 99# is use the first PDP by default.ATD* 99# is the same with ATD* 99** *1# .
About the problem of not being able to open the web pages,you can put your SIM card on your phone to see if you can access the Internet.

I tried the sim on the phone and the sim works.

  1. After excute AT+CGACT=1,1,please check AT+CGPADDR and give the screenshot to me.
  2. Find the dial-up, right click, select network and make sure TCP/Ipv4 is selected.
1 Like

Hi Winnie,
as required I am attaching the screenshot. As you can see the IP address is assigned

Do you have any other suggestions for me?

Have you fixed the IP address of the PPP dail-up?
From your screenshot,I saw DHCP is No and the Gateway is abnormal:

If the IP address is fixed, please change it to automatically obtain.
If it still doesn’t work, please contact