AT cmd port fail after set usbnet into RNDIS mode

the usbnet default mode is RMNET
at+qcfg=“usbnet”
+QCFG: “usbnet”,0
when insert to linux board, it will be enumerated as 4 usb serial port /dev/ttyUSB0…3
/dev/ttyUSB2 is for AT cmd

set usbnet into RNDIS mode
AT+QCFG=“usbnet”,3
2) then reset system
AT+CFUN=1,1

only 3 usb serial port /dev/ttyUSB1…3, and /dev/ttyUSB2 will not response to AT cmd

Dear Zhongtao,
Thanks for your inquiry in Quectel forum.
Just as you have said that if you change the usbnet mode to RNDIS, but it can not show the ttyUSB port, it is better to check your system configuration. Whether you have change the system setting to support RNDIS? Please double check it. Thanks!

thanks for your reply,

default mode usbnet RMNET, it will show 4 ttyUSB (ttyUSB0…3), and ttyUSB2 is for AT cmd,
when use minicom to open ttyUSB2, it will response successful to AT command input.

after change to RNDIS mode, it show only 3 ttyUSB (1…3), and ttyUSB2 will not response to
AT command input any more, the system config should be OK, would you please try it.
you can reproduce it as following
AT+QCFG=“usbnet”,3
AT+CFUN=1,1
thanks for any more reply,

Dear Zhongtao,
Please check the following guide to modify your option.c file. Thanks!

I have the same stupid problem.

NOW I CANT USE THE MODULE.

DO YOU HAVE SOME DECENT GUIDE TO RECOVER THE MODULE ???

WE ARE NOT CHINESE, YOU SHOULD SEND ENGLISH MANUAL

I’m tired of looking for the solution to this nefarious problem