About Eclipse software tool settings

Setup procedure of Eclipse
During the setup of Eclipse, Tool Settings under the c/c++ Build of Properties section, no option is coming.
I need to configure ''Preprocessor Macro" and ''Include path".
Please help me with this matter.

you need install Eclipse CDT plugin to support ARM
or use Eclipse from M66/M60 SDK - All plugins is installed

@ WizIO, Thank you for your reply.
I already installed Eclipse from M60 SDK and when it is not showing the ‘Tool Settings’ then I switched to the newer version of it and checked in the Eclipse marketplace which is showing ‘Eclipse C/C++ IDE CDT 9.8 (2019-06)’ installed.
In both the cases ‘Tool Settings’ is not showing.

install and use this Eclipse version - CDT is installed and work for ARM
http://www.quectel.com/ProductDownload/eclipse-cpp-kepler-SR2-win32.zip

I already tried this version of eclipse, but it is not showing tool settings in the system.
I had installed ‘arm-2012.09-63-arm-none-eabi’ gcc compiler and ‘eclipse-cpp-kepler-SR2-win32’ in several system.
I also installed it in windows 10 and windows 7, but in both the system it is not working.
After opening ‘Tool settings’- it is showing “Orphaned configuration. No base extension cfg exists for org.eclipse.cdt.cross.arm.gnu.sourcery.windows.elf.release.1040433350”

I reinstalled the old version i.e. what you’ve told, but again same problem is coming.


?!?!
try select manualy

Thank you.
Now, when I’m going to build the project, in Make Target -> Build ---- nothing is coming.

Are File->Open or File->Import SDK ?
There is manual ( OpenCPU_GCC_Eclipse_User_Guide_V1 0_Preliminary.pdf )
how to set Eclipse for Quectel SDK

I have already done all the things written in the manual.
But besides that, these problems are coming.
Okay, I’ll post one video regarding what is happening, it’ll be better to show all the problems.

BTW: If you know VSCode + PlatformIO you can try my solution for Quectel
There is standart SDKs for M66, M60, BC66, BG96, ECx(commming soon)
plus Arduino applications inside modules

Thank You @WizIO. You Helped me a lot.
I’ll definitely try this solution and will let you know.