Quectel EC25 Mini PCIe USIM detection problem (USIM_VDD=0V)

Good afternoon,

we also have an issue with the hot-swap/usim_detection function and we can not find a solution in this thread yet. We are using the EG25GGB-256-SGNS LGA Version with Firmware EG25GGBR07A07M2G .
Below you will find a schematic part of the SIM interface, which is designed as the reference circuit in the datasheet. The problem is, that the hot-swap function seems not working. When hot-swap function is disabled, the SIM Card is detected, communication is working and everything is fine.

What we already checked:

  • AT Commands are correct (the same steps as mentioned in other posts)
  • 1.8V is coming from the module (VDD_EXT) and is stable
  • insertlevel is set to the right level (tested both levels)
  • module is restarted.
  • switch of the card reader is switching clean (no bouncing, no contact resistance). But what I recognized is, that the voltage level at USIM_PRESENCE is only 1,2V when the switch is closed. With a lower pull-up resistance, voltage level rises! This is not the expected DC characteristic from the datasheet. If R52 is removed, the signal switches between 0V and 1,8V as I expected.

Thank you very much in advance

Dear JayAr,
For SIM card hot plug function, EG25-G supports (U)SIM card hot-plug via the USIM_PRESENCE pin. The function supports low level and high level detection. By default, it is disabled, and can be configured via AT+QSIMDET command. And this PIN is 1.8 V power domain.
So for your issue, it is better to double check it, such as whether the pin level will change after you set it, and confirm whether it is correct. Hot-swap function takes effect after the module is restarted.

Dear Kyson,

my Software colleague is present again so we were able to double check everything.
(At first, there is a mistake in my first post, where I wrote voltage level at usim_presence is 1,2V when switch is closed. I meant, when switch is open)

  • when hot-swap is not set and card reader switch is open, the voltage level at usim_presence is 1,2V.
  • when hot-swap is set and card reader switch is open, the voltage level at usim_presence is 0,65V.
  • when hot swap is set by QSIMDET command we get an OK, but after restarting the module there is no reaction when SIM Card is inserted/removed. After restarting the module, the card detection is still set but hot-swap still does not work.

Dear JayAr,
Please double check the USIM_Presence should be pull up to VDD_EXT with 51k resistence. For hardware design, please make sure your design is the same as the following reference. And for software, just need to pay attention to whether the setting is take effect after reboot the module. Thanks!

Dear Kyson,

our design is almost identical to the Quectel reference design (see schematic of my first post).
I unsoldered and measured R52 (0 Ohm) and R51 (56k Ohm), measured VDD_EXT again (1,8V, stable) checked the card reader and the layout data. I could not find any inconsistency.
Still, after rebooting the module we do not get any interrupt when inserting or removing SIM card (e.g. +CPIN: NOT READY / +CPIN: READY). But the function is enabled because response to AT+QSIMDET? is +QSIMDET: (1,0) OK or +QSIMDET: (1,1) OK (tried both insertion levels).

Also when SIM card is inserted:
If Hot-Swap function is enabled, response to AT+QSIMSTAT? is +QSIMSTAT: (1,0).
If Hot-Swap function is disabled, response to AT+QSIMSTAT? is +QSIMSTAT: (1,1).

Dear JayAr,
If the hardware design and software design are the same, the hot-swap still cannot take effect. The only method maybe you can try to upgrade the firmware to have a try. Please email to support@quectel.com to get the latest firmware and upgrade tool to have a try, you also can get the local support via the above email. Thanks!

I’m having the same issue here, but was wondering if the missing 15k pull-up between USIM VDD and DATA could be the cause.

Posted detail here

You can have a try to connect it and confirm whether it still have such issue. Thanks!

@Kyson

Yes, that’s my plan ultimately, but just want to find some documentation to guide along troubleshoot rather than trial and error to reverse engineer.

Given that the 0V Vdd isuess does not happen consistantly, and currently unsure how to re-produce. Even if the resistor is working after soldered, I have no ways to know this is exactly the solution.

Also 2 reasons led me to ask for background logic:

  1. Most of the terminal devices with EC25 works flawlessly and non of them has the pull up resistor
  2. I do have another brand terminal that uses EC25, and its manufacture also decided to skip this pull up as well, it must be for a reason

Dear Robin,
For such issue, there have no such document to guide you how to find the reason, just share some tips with you. Hopefully it is useful to you. Thanks!
1.The most important is to follow up the reference design to design your own circuit.
2. About the SIM card issue, it is better to check whether the SIM slot have any connect issue, and use AT+CPIN? to check whether the module have recongize the SIM card.
3.If not, it is better to check the voltage of SIM_VDD, we recommend you use oscilloscope to check it from power on the module.
4. You also can check the waveform of SIM_CLK, SIM_DATA to check whether there have any interference on it. Of course, you need to check the layout before do it. Thanks!

I tried to add i nthe 15k pull up resistor and made no improvement, the sim circuitry is exactly same asm refernce. So still stuck…

I did manage to speak with one of you company rep who explained that on boot logic. It detect sim with both 3V and 1.8V, for 3 times, if all 3 times failed, then VDD is shut off.

Still doesn’t explain why the Sim cant be detected

Anyone got any further ideas? Or anyone got any luck with a scope? I don’t have one.

@Kyson

Here’s another user with same issue

Problem is, if voltage fluctuates than this problem happens.
First, Quectel must accept that problem and try to solve it.

In one thread @Kyson says send AT+CFUN = 0 than send AT+CFUN=1 but it does not work too.

This problem is not a problem that customer can solve. I do not know why Quectel side insist to deny this problem. It is not a problem that is little.

This is very important problem. Think it a little, I sell a device than it does not connect internet. Because it does not detect sim card.

You can also create that problem at office too. While device is working fluctuates voltage and than that happens.

So, guide to solve that problem by software.

Dear Robin_Xiao,
The module’s behavior of SIM detect is the same as the above said, you can check the waveform of SIM_VDD start from power on module, and confirm whether it is the same as we said. If it is different, it may be related to module hardware or software, if it is the same, you may need to check the external SIM card circuit to confirm whether there have any abnormal, you can try to weld another SIM holder connect to module SIM pins to confirm it. Thanks!
@SmartEq_Bilisim In order to solve the issue, we need to confirm where is the issue firstly. Thanks! What we can confirm is that we have test the module hardware and software before you get it, and the module is normally. Now what we need to confirm your test method, your hardware design…Thanks!

Whe have the same problem too. EC25-E does not recognize SIM cards. We welded card holder to the board, but it does not work:
minicom *********
at+cfun=1
OK

+CPIN: NOT INSERTED

qmicli:*********
root@t1042d4rdb:~# qmicli --device=/dev/cdc-wdm0 --uim-get-card-status
[/dev/cdc-wdm0] Successfully got card status
Provisioning applications:
Primary GW: session doesn’t exist
Primary 1X: session doesn’t exist
Secondary GW: session doesn’t exist
Secondary 1X: session doesn’t exist
Slot [1]:
Card state: 'error: no-atr-received (3)
UPIN state: ‘not-initialized’
UPIN retries: ‘0’
UPUK retries: ‘0’
root@t1042d4rdb:~#

If that, it is better to check the waveform of SIM_VDD, SIM_DATA,SIM_CLK of the module start from power on module.Thanks!

I am using EC20CEHCR06A03M1G on sixfab rasberry 3g/4g Hat, and I am unable to detect sim, even after trying several time. Please help me get the exact issue with the board. I have at+cfun=1, I tried at+qsimdet=1,0
OK
at+cops?
+COPS: 0

OK
at+cops=1
ERROR
at+cpin?
+CME ERROR: 10

and much more than that, but its failing badly. I have tried with two different sims, each working fine on the mobile.

If that, please check the hard design circuit of SIM card in your board. Thanks!

Hi again,
After a long and tedious process, we realize that problem is about SIM card connector’s pin. Their contact are are not wide pins are thin.

Thank you.

Thank you all, this thread was very helpful.
I Believe my system is suffering from the same issues.
Sim card sometimes not detected and it solved by rebooting the system (without touching it).

Can please provide More details/photos of good vs bad contacts?

Hi Sir,

Can you please clarify what are the dimension of a wide vs thin pins?
The contact should be wide, is what you sugest, right?
Thank you very much