M66 MQTT commands

If I have given
AT+QMTCFG=“ssl”,0,0,1
AT+QSSLCFG=“sslversion”,0,0
AT+QMTOPEN=0,“cloudmqtt name”,port number
it is displaying OK
+QMTOPEN:0,-1
I want to know correct response and in AT+QMTOPEN port number should be port or SSL port
Regards,
Swathi.

Dear Swathi,
Thanks for your inquiry in Quectel forum.
If you want to test M66 MQTT with SSL function, it is better to follow up the example to upload the authentication to module. Please double check it. Of course, if you test MQTT without SSL, you should not use AT+QMTCFG=“SSL” and AT+QSSLCFG=“sslversion”. Then it is better check whether the MQTT server you test is ok or not. Thanks!

Is that mandatory to set AT+QSECWRITE command, how can I get CA and CC.

If I give AT+QMTCFG=“SSL”,0,1,2
response +CME ERROR:3765

Dear Swathi,
Please note that if your test MQTT server do not support SSL, of course you do not need to use AT+QSECWRITE command.
Otherwise, if your server support SSL, you must use the command to upload the needed authentication file to module, and the file is come from your MQTT server, not Quectel. Thanks!

Ok
Thank you for response,
If I give AT+QMTCFG=“SSL”,0,1,2
response +CME ERROR:3765
AT+QMTCFG=“SSL”,0,0,1
response ok

Dear Swathi,
Please check whether your MQTT support SSL. Thanks!
From your description, i think the MQTT server you used is not support SSL, so i ask you double check it. Thanks!


image
image
image

If I give AT+QMTOPEN=0,“servername”,port
I have given cloud mqtt details servername and port, which I have logged in
it is displaying +QMTOPEN:0,4 means failed to parse domain
Please help me with the details.

I have added port number issue has solved. If I give AT+QMTCON=0,“servername”,“username”,“password”
response is +QMTSTAT:0,1
help me to find the solution.

1 Like

Dear Swathi,
It is better to check whether there have any mistake when you enter the command.

The following is the explanation of the QMTSTAT, please check. For your issue, it is better to excute AT+QMTOPEN and reopen MQTT connection. Thanks!

1 Like

Hi sir,
when I give “AT+QMTOPEN=0,“m21.cloudmqtt.com”,11308” in code it is giving error response.
When I give this command in QCOMM it is giving me ok response.
Please help us with a solution.

Dear Swathi,
Please provide your whole test AT log to me, then we can confirm your issue. We need to confirm whether there have any error parameters setting in your test. Thanks!


For AT+QMTOPEN and QMTCONN all should have the following response, if you have not seen it. It is abnormal. Thanks!

Hi sir,
when I give AT+QMTOPEN=0,“url”,port
response ok
when I give AT+QMTCONN=0,“url”,“username”,“password”
response +CME ERROR: 3518
please help me with a solution.

Dear Sir,
Could you help try to follow up the following example to set AT+QMTCONN, the second parameter is clientID, not URL. Thanks!

Hi sir,
when I give AT+QMTOPEN=0,“m21.cloudmqtt.com”,11308
response ok
AT+QMTCONN=0,“m21.cloudmqtt.com”,“user”,“password”
response +CME ERROR:3518

Dear Swathi,
Please check the answer to your question. Thanks!


image

Sir it is not url it is server name of cloud mqtt, please suggest me what to keep there

Sir,
we are using 4BT firmware version, 4BT firmware should use which SDK version. Please share me the link of SDK version.
I have dumped SDK version and checked mqtt commands it is working.

Dear Swathi,
What is the meaning of 4BTfirmware, if you want use to help check the matched SDK version, it is better to provide the whole firmware version. Thanks!

Hola yo tambien tengo el mismo problema, me dice parametro invalido
image