How can I customised the HTTP header?

I am using EC25J now and I need to send HTTP GET request to our server, but HTTP header “Authorization: xxxxxxxxxx” is required, I try to set the AT+QHTTPCFG=“requestheader”,1 and package the HTTP req by myself, but it response CME: 701, please check the HTTP data as below:
‘GET /v1/device_modes/1234 HTTP/1.1\r\nHost:\r\nAuthorization: NeRQrYM9dfenADGT26sSSADFCQJJEXVQK\r\n\r\n’

Dear Jackie,
Thanks for your inquiry in Quectel forum.
About your issue, please double check whether your server can support customize HTTP(S) Request Header, if not support, please change the setting; if it can support, please confirm whether the header is the same as the server required. Thanks!
The following document is HTTPS applictaion note, please double check it. Thanks!
Quectel_LTE_Standard_HTTP(S)_Application_Note_V1.1.pdf (394.7 KB)