Getting started with bc660 gl EVB

default firmware for ATCommands? I am unable to get the response using tool.
but no response as well as in logfile it was empty

Do you use the UART port (main_tx\main_rx)? The baud rate is set to 115200
Do you have log output when you reboot or repower?

yes using main uart and baud rate set is 115200 please find the screenshot here attached
i have the building logs or flashing logs…
where can i see the log output while reboot or repower?

Based on discussion, Just to verify and no confusions, I followed the steps is as follows:
connected EVB using usb cable and built the gpio example and led example seperately and flashed using Qflash tool provided by @herbert.pan-Q. Now to debug or see the logs how can i see them?
later I tried communicating via AT commands using tool provided by you but was unable to get the response.

Thanks in advance for the support and correct me if I am wrong. All work is done on EVB using Jio NB-IoT simcard.

Please upload your device picture

please find the device pictures

Is the firmware for the current module open SDK? I suggest you debug using standard firmware first

please share the standard firmware.

currently using the sdk shared by @herbert.pan-Q 8 days ago.
tried gpio example as well as led blink d304 but had idea to debug the print statements.

please download by link

the firmware is supporting to ATcommands debugging using QCom tool?

The response I get is not readable tried changing baudrates too. but no idea why this is the issue?

I am also very confused, please restart your PC or check the cable

I am able to get responses thanks.
I want to understand now getting debug statments building examples like mqtt, tcp,etc

Hi @herbert.pan-Q I am trying to use AT Commands for mqtt communication with aws iot things.
I tried below flow but showing errors:


[2022-05-17_13:24:39:992]AT+QSSLCFG=0,0.“seclevel”, 2


please refer to the document
Quectel_BG95_Series_AWS_IoT_Platform_Access_User_Guide_V1.0_Preliminary_20200825.pdf (1.4 MB)


[2022-05-18_11:44:09:202]+CREG: 0,6

[2022-05-18_11:44:00:919]+CEREG: 0,1

Is this blocking the registration? as 6 represents not registered?

It indicates that the module successfully registered the radio network

at+cgpaddr //query the IP from the network


[2022-05-18_12:06:09:129]+CGPADDR: 0,“2405:0203:4224:3c15:0000:0000:3288:a00b”


working fine

can you please help me with mqtt example without using ssl and using other mqtt server not alibaba