Firmware for RM502Q-AE

Can you provide the latest firmware for the RM502Q-AE?

Thanks in advance.

I currently have the revision RM502QAEAAR11A04M4G, can I install the revision RM502QAEAAR13A02M4G with Qflash 5.8 on Windows ?

I do not recommend you upgrade to RM502QAEAAR13A02M4G;R11 to R13 have changed the chip software baseline version

Hi can you please share the download link for the version (R11) firmware for the RM502Q-AE?

Is there a version (R12) that was after version (R11) and before version (R13)?
I see you dont recommend version (R13) so can you share the version you recommend and the firmware pls?


Hi Herbert,
I see you shared the RG502Q-AE, but my modem is a RM502Q-AE.
Can you share that link for version R11 of RM502Q-AE and version 12 if exists?

Also per your post I tried this command to just try to reset me Modem but I can’t find anyway to reset the modem IMEI to factory.

I also tried to upload the firmware (R13) to run the update and reinstall RM502QAEAAR13A02M4G (R13 version) but it says it is out of space so cant finish copying it up. I have no idea what files I could delete from the modem when I SSH into it.
QFirehose -f /tmp/updatefw

Are you aware of any command to reset IMEI and SN# to factory or just an autoselection so it automatically recognizes the SIM when installed??

I read in another forum that you need to update QFirehose to fix that issue. just updated to the latest autobuild ROOter if that’s what you are using.

And here is the latest R11

RM502QAE AAR11A04M4G_01.004.01.004

Hi mrgodai,
Thanks for the link for (R11).
I am not using QFlash and just used WINSCP to copy the firmware folder to the modem.
When I try to copy it over it gets to about 90% complete then says out of space.
My plan after copying the file to the modem is to connect with putty and run the command
“QFirehose -f” from the copied firmware folder /tmp/updatefw.

Not sure how to update QFirehose as its just a file in one of the firmware update folders.
example: Quectel_RM502Q-AE_Firmwares\RM502QAEAAR13A02M4G_rev13\update\

Hi, is there an AT command to restore the IMEI and SN# to default for an RM502Q-AE ?
Seems strange I would have to reinstall the firmware to fix this issue.

there isnt enough space on the RM502QAE to let you copy the firmware there and THEN flash it.

If you have RM502 module, you can attach it anywhere, using a m.2 to usb adapter, and you can flash it on windows.
Also on linux if you want to use Qfirehose.
You don’t upload the firmware folder to the modem,but on the system where you have it installed.
If it’s a router, and you can use ROOter, it is your best bet, Because ROOter have latest qfirehose, but you need to have a router whit 500 mb of ram, or usb storage, where to drop the firmware folder.
you can also update remotely whit Qfirehose.

Here is my challenge, the Quectel (R13) version is not picking up my 5G bands.
When I run an AT+QSCAN=3 it shows no 5G bands but I know for a fact I can see band n71/n66.
When I run AT+QSCAN=2 it just comes back with ok. It does not list any other output and that is supposed to be the exclusive 5G band scan.

In an earlier post I see that it was not recommended to run version (13) for the RM502Q-AE and that version (R11) was recommended. Does that recommendation have anything to do with me not seeing 5G Bands? I have all bands (4G/5G) selected in my modem. I do the scan without the SIM after powering down and back up.

Need your guidance on the Quectel team!

More diagnostics to help troubleshoot this:
+COPS: (2,“T-Mobile”,“T-Mobile”,“311490”,7),(1,“Sprint”,“Sprint”,“310120”,7),(1,“312 250”,“312 250”,“312250”,7),(1,“AT&T”,“AT&T”,“310410”,7),(1,“313 100”,“313 100”,“313100”,7),(1,“311 882”,“311 882”,“311882”,7),(1,“Verizon”,“Verizon”,“311480”,7),(1,“312 530”,“312 530”,“312530”,7),(0-4),(0-2)

For this command it will disable 5G Mode (AT+QNWPREFCFG=“nr5g_disable_mode”) I want to enable 5G NR bands

AT+QNWPREFCFG=“policy_band” output:
+QNWPREFCFG: “gw_band”,1:2:3:4:5:6:8:9:19
+QNWPREFCFG: “lte_band”,1:2:3:4:5:8:12:13:14:17:18:19:20:25:26:28:29:30:32:34:39:40:41:42:43:46:48:66:71
+QNWPREFCFG: “nsa_nr5g_band”,1:2:3:5:7:8:12:14:20:25:28:38:40:41:48:66:71:77:78:79
+QNWPREFCFG: “nr5g_band”,1:2:3:5:7:8:12:14:20:25:28:38:40:41:48:66:71:77:78:79

AT+QNWPREFCFG=“mode_pref” output:
+QNWPREFCFG: “mode_pref”,NR5G

Cell Scanner Start …after enabling only NR5G

No Neighbouring cells were found

Just to prove that I am not crazy and get a 5G signal,
I plugged in my Calyx M2000 MIFI and it is showing it is connected to Band n71 /5G without an external antenna.

I dont know if the RM502Q-AE supports 5G yet???

It does. I’m on R11A02 and connecting to tmobile band 2 LTE and n41 5G.

you might want to try a lower firmware as i’ve read some people have issue with 5G on R13 and even R11A04 in their areas

Hey thanks, I did install (version R11) but had the same results.

Hey Quectel Support, LTE user forums are reporting that the RM502Q-AE is not connecting to 5G NR bands. Only the RM500 model is connecting to 5G. They are reporting that something has recently changed and broken the 5G access.

Can you share any information about this?

Quectel_RG50xQ_Series_5G_Specification_V1.5.pdf (362.2 KB)

in this pdf you linked, it states RG502Q-EA doesn’t support N78 in 5G-NSA mode.
But it actually does.

1 Like