EP06-E over USB identified as 05c6:9008

This looks like power related problem. Have he tried it on a different platform?
No issues with EP06ELAR03A08M4G on my side, I’m using it on several EP06 modules.

1 Like

First of all… massive thanks to you @pepe2k! I actually now saw 4 ttyports on Linux. So this device is alive. I probably just then got a device without any firmware.

But yeah. Device keeps on unregistering with EP06ELAR03A08M4G. It might be a power issue. But this is a massive improvement to earlier state already.

[114157.918591] usb 1-1.3: new high-speed USB device number 37 using xhci_hcd
[114158.019526] usb 1-1.3: New USB device found, idVendor=2c7c, idProduct=0306, bcdDevice= 3.10
[114158.019535] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[114158.019539] usb 1-1.3: Product: EP06-E
[114158.019544] usb 1-1.3: Manufacturer: Quectel
[114158.019548] usb 1-1.3: SerialNumber: 0123456789ABCDEF
[114158.026753] option 1-1.3:1.0: GSM modem (1-port) converter detected
[114158.027304] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
[114158.027501] option 1-1.3:1.1: GSM modem (1-port) converter detected
[114158.028304] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
[114158.028507] option 1-1.3:1.2: GSM modem (1-port) converter detected
[114158.029249] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2
[114158.029444] option 1-1.3:1.3: GSM modem (1-port) converter detected
[114158.029571] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3
[114158.031833] qmi_wwan 1-1.3:1.4: cdc-wdm0: USB WDM device
[114158.032368] qmi_wwan 1-1.3:1.4 wwan0: register 'qmi_wwan' at usb-0000:01:00.0-1.3, WWAN/QMI device, 76:4b:fd:dc:71:ec
[114163.217193] usb 1-1.3: USB disconnect, device number 37
[114163.217823] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[114163.217915] option 1-1.3:1.0: device disconnected
[114163.218534] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[114163.218619] option 1-1.3:1.1: device disconnected
[114163.219364] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[114163.219454] option 1-1.3:1.2: device disconnected
[114163.220158] option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3
[114163.220243] option 1-1.3:1.3: device disconnected
[114163.220537] qmi_wwan 1-1.3:1.4 wwan0: unregister 'qmi_wwan' usb-0000:01:00.0-1.3, WWAN/QMI device

I will inject some extra power into it to see if that helps it unregistering.

I added extra 3.3V supply to the circuit, but issue still continues … so looks like I chose the wrong firmware. So there is no way to force device back to emergency download mode, to allow me to try another firmware?

I also pulled RESET_N up to make sure it’s not causing this, but that didn’t help.

If it is already normal in your Linux system, but it is abnormal in Windows system. You use the same module with the same firmware version, right ?
It is better to check the difference between the Linux test environment and Windows test environment, as you know that just the test environment is the variable. It may not the module firmware issue. Thanks!

It’s having identical issue on Windows now. So I can’t reflash it, as device stays up for few seconds only, before restarting itself.

So it never was normal, it just identified itself now correctly. But where before it felt like it didn’t have firmware. Now it has firmware but keeps crashing after few seconds.

Dear Alump,
If it is normal in Linux system, please try to send AT+QCFG=“usbnet” to check the default value. If the return value is not 0, please try to use AT+QCFG=“usbnet”,0 to reset it. Then reboot the module to have try again in Windows system. Thanks!

I would, if the device wouldn’t unregister and restart itself before i manage to send the first byte to AT port.

Some Quectel modules have USB_BOOT pin i could pull up/down to force device to start in emergency download mode. But EP06 doesn’t have this? Can’t find any mention on documentation.

EDIT: EG06 has the pin, but can I “easily” access it on this mPCIe card?

Dear Alump,
Yes, EP06 also have such pin, we have reserved the test point, please check the following picture. Thanks!
Please connect the two pins before power on module, then after the QDloader port appeared, please disconnect them. Thanks!
image

1 Like

Thanks, that did the trick. I managed to try flashing again, this time with EP06ELAR02A03M4G firmware, and it worked. At least device stays up now, and I can talk with AT port. Thanks again.

Ok, looks like many AT commands are returning Memory Error codes (23). Maybe I cheered too soon.

Dear Alump,
The firmware EP06ELAR02A03M4G is quite old, so may be some commands cannot support on such version. You may upgrade to latest version to have a try. You can email to support@quectel.com to get the latest fimware package. Thanks!

Did you also buy your modem on Ali (like @arni user)? He had the same problem.

Yes, it’s from AliExpress.

:frowning:
I wouldn’t be surprised if you got some fake/counterfeit or just damaged one.
Next time buy from official distribution/sources.

…and the official list of distributor/sources is available at?

EDIT: Looks like we have used different sellers on AliExpress, of course that doesn’t mean anything. Most like those are sold from the same piles.

It’s no longer on their website, so probably you should contact with their sales dep.

I suppose there should be a way to confirm with Quectel whether the module is original and where it comes from, based on S/N and/or IMEI.

Ok, the V06 flashing just didn’t want to work. so I went with one last one try with V08. But device is back into reboot loop. I lost the USB_BOOT pad (that’s my own fault) - so I think I will just throw this away, and try with another manufacturer and seller. Anyway, here are the autopsy images. Seller says it authentic, but there is no way to tell if seller is valid seller… so who knows.

https://photos.app.goo.gl/WSEJeQKKv3DJTgTn7 and https://photos.app.goo.gl/jabbZitJmZQq6GMw7

Fighting with this killed some time anyhow, which is nice on these lockdown times.

Dear Alump,
If you want to buy module online, we also have official Tmall flagship store, you also can check it. It is operate by Quectel, the module quality can be warranted. Thanks!
The following is the address, you can have a look. Thanks!
https://yiyuanznsb.tmall.com/shop/view_shop.htm?spm=a230r.7195193.1997079397.2.17a5a5c0JooVDh

@Kyson I check offer at Tmall and they are only EC20 at 4G, without EP06-E !.
Only one offer exist with EP06-E and this is not at your store!

Then better if you provide a proper store with product at TMall or URL exacly to product.
Or provide information that in Poland is a distributor like:https://soyter.pl and who is in German ? - Soyter say they are a distributor like the same AliExpress sellers like “emaxgroup.hk” and how we can check if the seller REALY is or not a distributor ?

@alump post last post with photo with SN and IMEI - you can check that device is/was buy with proper distributor ?