EP06-E - Modem lost the ability of making calls, GNSS and send SMS after upgrade to the last firmware

Hello Everyone! :slight_smile:

My modem, an EP06-E, lost the ability of making calls, GNSS and send SMS after upgrade to the last firmware. (v A20), before the upgrade, the modem did all supported functions, but with unstable data (internet) connection.
After the upgrade, data connection got consistent and stable, but all other supported functions are gone…
Any ideas or suggestions will be highly appreciated.

Thank you beforehand,

Regarding GNSS:

  • make sure you have a serial port with “NMEA” in its name (I guess you’re using Windows)
  • open any terminal app you have and query your modem (through AT command port) with the following commands:

/* Start AT SYNC: Send AT every 500ms, if receive OK, SYNC success, if no OK return after sending AT 10 times, SYNC fail */
[2023-11-14 00:15:56:955_S:] AT
[2023-11-14 00:15:57:011_R:] AT
[2023-11-14 00:15:57:011_R:] OK
[2023-11-14 00:15:57:013_S:] ATI
[2023-11-14 00:15:57:066_R:] ATI
[2023-11-14 00:15:57:066_R:] Quectel
[2023-11-14 00:15:57:066_R:] EP06
[2023-11-14 00:15:57:066_R:] Revision: EP06ELAR04A20M4G

[2023-11-14 00:15:57:066_R:] OK
[2023-11-14 00:15:57:069_S:] ATI
[2023-11-14 00:15:57:122_R:] ATI
[2023-11-14 00:15:57:122_R:] Quectel
[2023-11-14 00:15:57:122_R:] EP06
[2023-11-14 00:15:57:122_R:] Revision: EP06ELAR04A20M4G

[2023-11-14 00:15:57:122_R:] OK

/* Use ATV1 to set the response format */
[2023-11-14 00:15:57:328_S:] ATV1
[2023-11-14 00:15:57:381_R:] ATV1
[2023-11-14 00:15:57:381_R:] OK

/* Use ATE1 to enable echo mode */
[2023-11-14 00:15:57:632_S:] ATE1
[2023-11-14 00:15:57:686_R:] ATE1
[2023-11-14 00:15:57:686_R:] OK

/* Use AT+CMEE=2 to enable result code and use verbose values */
[2023-11-14 00:15:57:836_S:] AT+CMEE=2
[2023-11-14 00:15:57:895_R:] AT+CMEE=2
[2023-11-14 00:15:57:895_R:] OK

/* Get the baudrate, if the value is 0 (auto baudrate), then it will be set to 115200 (fixed baudrate) to assure reliable communication and avoid any problems caused by undetermined baudrate between DCE and DTE, value of IPR should be saved with AT&W */
[2023-11-14 00:15:58:149_S:] AT+IPR?
[2023-11-14 00:15:58:203_R:] AT+IPR?
[2023-11-14 00:15:58:203_R:] +IPR: 115200

[2023-11-14 00:15:58:203_R:] OK

/* Use ATI to get module information of Manufacturer ID, Device module and Firmware version */
[2023-11-14 00:15:58:254_S:] ATI
[2023-11-14 00:15:58:308_R:] ATI
[2023-11-14 00:15:58:308_R:] Quectel
[2023-11-14 00:15:58:308_R:] EP06
[2023-11-14 00:15:58:308_R:] Revision: EP06ELAR04A20M4G

[2023-11-14 00:15:58:308_R:] OK
[2023-11-14 00:15:58:316_S:] AT+QURCCFG=“URCPORT”,“usbat”
[2023-11-14 00:15:58:370_R:] AT+QURCCFG=“URCPORT”,“usbat”
[2023-11-14 00:15:58:370_R:] OK

/* Use AT+CPIN? to query the SIM card status : SIM card inserted or not, locked or unlocked */
[2023-11-14 00:15:58:877_S:] AT+CPIN?
[2023-11-14 00:15:58:931_R:] AT+CPIN?
[2023-11-14 00:15:58:931_R:] +CPIN: READY

[2023-11-14 00:15:58:931_R:] OK

/* Use AT+CIMI to query the IMSI of SIM card */
[2023-11-14 00:15:59:049_S:] AT+CIMI
[2023-11-14 00:15:59:102_R:] AT+CIMI
[2023-11-14 00:15:59:102_R:] 240078237247914

[2023-11-14 00:15:59:102_R:] OK

/* Use AT+QCCID to query ICCID number of SIM card */
[2023-11-14 00:15:59:256_S:] AT+QCCID
[2023-11-14 00:15:59:310_R:] AT+QCCID
[2023-11-14 00:15:59:310_R:] +QCCID: 89462048009165471765

[2023-11-14 00:15:59:310_R:] OK

/* Use AT+CSQ to query current signal quality */
[2023-11-14 00:15:59:362_S:] AT+CSQ
[2023-11-14 00:15:59:416_R:] AT+CSQ
[2023-11-14 00:15:59:416_R:] +CSQ: 19,99

[2023-11-14 00:15:59:416_R:] OK

/* Use AT+CREG? /AT+CGREG? to query the network registration status. */
[2023-11-14 00:15:59:424_S:] AT+CREG?
[2023-11-14 00:15:59:483_R:] AT+CREG?
[2023-11-14 00:15:59:483_R:] +CREG: 0,1

[2023-11-14 00:15:59:483_R:] OK
[2023-11-14 00:15:59:496_S:] AT+CGREG?
[2023-11-14 00:15:59:550_R:] AT+CGREG?
[2023-11-14 00:15:59:550_R:] +CGREG: 0,1

[2023-11-14 00:15:59:550_R:] OK

/* Use AT+COPS? to query current Network Operator */
[2023-11-14 00:15:59:603_S:] AT+COPS?
[2023-11-14 00:15:59:657_R:] AT+COPS?
[2023-11-14 00:15:59:657_R:] +COPS: 0,0,“Tele2 Comviq”,7

[2023-11-14 00:15:59:657_R:] OK

/Use AT+CEREG? to query current EPS Network Registration Status/
[2023-11-14 00:15:59:710_S:] AT+CEREG?
[2023-11-14 00:15:59:764_R:] AT+CEREG?
[2023-11-14 00:15:59:764_R:] +CEREG: 0,1

[2023-11-14 00:15:59:764_R:] OK

[2023-11-14 00:18:38:988_S:] AT+QGPSCFG?
[2023-11-14 00:18:39:044_R:] AT+QGPSCFG?
[2023-11-14 00:18:39:044_R:] +CME ERROR: Operation not supported

[2023-11-14 00:19:43:647_S:] AT+QGPS?
[2023-11-14 00:19:43:701_R:] AT+QGPS?
[2023-11-14 00:19:43:701_R:] +QGPS: 0

[2023-11-14 00:19:43:701_R:] OK

Your GNSS function is off.

There is no need to post all this irrelevant information.

Hello @jfrog
Good Morning, What set of commands I can use to re-enable all features back?
I’ve tried to reset the modem without any results.
AT&F don’t worked.
Thank you beforehand


Google for “LTE-A(Q) Series GNSS Application Note”

Hello @jfrog
Thanks for the gps commands, I’ll try later.
Do you have any ideas to restore phone calls and SMS abilities?
Once again, thank you.
Have a nice evening

No ideas about voice, sorry.
For SMS I suggest following the example below and post the error, if any.

These commands are standard, e.g. not specific to Quectel, you can run them on any modem you have to compare results.

Hello @jfrog ,

All links of downloads are dead and simply does not work. Error 404.
Do you have any ideas of alternative sources?
Once again, Thank you! :slight_smile:

There is no need to download anything. You just need to send a few AT commands from the terminal.

@jfrog All sharepoint links are dead, simple as this is.
If you can, i humbly beg you, can you list that commands?
Thank you beforehand

You only need what is called Example in the post I linked.
Alternatively google for something like “at commands to send sms”.

Yes, please, if you don’t mind :slight_smile:

@jfrog Hello again,

About phone calls, I’ve tested with SIM card that fully works on the cellphone,and the log result was:

/* Use ATD; to dial up */
[2023-11-14 20:52:30:986_S:] ATD0739451606;
[2023-11-14 20:52:31:047_R:] ATD0739451606;
[2023-11-14 20:52:31:047_R:] ERROR
[2023-11-14 20:52:34:052_S:] AT+CLCC
[2023-11-14 20:52:34:116_R:] AT+CLCC
[2023-11-14 20:52:34:116_R:] +CLCC: 1,1,0,1,0,“”,128
[2023-11-14 20:52:34:116_R:]
[2023-11-14 20:52:34:116_R:] OK

What could happen?

Thank you beforehand,

How were you sending SMSs previously?

Hello @snowgum ,with Qnavigator, and worked fine before firmware update, after, not work any longer…

Qnavigator is not something I’ve used, so sadly I have no insights into what may be going wrong.

Hello @snowgum , thank you for reply me